Sending corrections to field genius

I want to use my Reach RS2 with field genius for android. The problem is that the CORS network in my area is TCP only rather than NTRIP. Currently, field genius doesn’t support TCP corrections, it only allows NTRIP. I’m able to get corrections in the reach view app using TCP and I was hoping to solve the problem with field genius by sending the corrections to my android tablet from the RS2 via Bluetooth. There is an Emlid instructional video that mentions this exact topic but it doesn’t provide details on how to set up field genius to receive corrected input via Bluetooth. The only options I see in field genius are “NTRIP” or “No RTK”. Any suggestions or input on this subject would be much appreciated.

1 Like

I haven’t used Field Genius but can it use the Android GPS as a source? If so, mock locations using Lefebure NTRIP will do the trick.

Bluetooth is by the book. Have you tried it and are not getting corrections? All you should have to do is get everything setup in Reachview, confirm that there is a fixed solution and setup the BT connection using No RTK.

Ok thanks Michael. I’ll give that a try once I establish a connection with the ALDOT CORS network. I need to back up a step and get that going first, then I’ll be in business. Maybe you can also help me with that. When I was using an iPad and ReachView everything worked great by sharing the mobile internet connection via hotspot. With that setup I can get corrections. However, with my android tablet, I’ve had no success. When I share the mobile data via hotspot, the reach unit will not connect like the iPad did. I know it’s basic stuff, but I can’t get it to work like it did with the iPad. I can’t find a video on sharing an android based mobile connection with reach to get corrections.

When you share the mobile connection, is the SIM in your Android? And is the problem just trying to get the Reach connected to the hotspot or is it in Reachview when you try to access the Reach? What I found is that on certain Android phones, I need to disable bluetooth for the app to work correctly. If I don’t, I get a connection time out message when I select the Reach receiver.

Yes the sim is in the android tablet and the problem is getting the reach connected to the hotspot.

The first thing I’d do is to connect to the Reach’s hotspot and forget all its saved SSIDs, then make a new entry to see if this works.

1 Like

I have seen this as well, but that is the connection used to communicate between the rover and FieldGenius so it was more of a forget it and reconnect.

Also, make sure you Bluetooth corrections from the rover being read in are in ERB format instead of NMEA.

1 Like

Thank you. I’ll try it this afternoon. But to confirm my assumptions, I do need to connect to the tablet hotspot to receive corrections just like I did with the iPad, correct?

1 Like

From what I understand from your setup, yes. No internet, no corrections, so Reach needs to be on the SIM-carrying device’s hotspot. Now I’m curious though and I’ll try that myself. What happens if I successfully connect to the Reach in Reachview and then enable bluetooth on my phone. In the past, I just used a second device for BT reception.

As you mentioned it can be sketchy on Android. My problems were always in the reverse where I had to turn off broadband for WiFi to stay connected consistently. There’s no good reason why you shouldn’t be able to connect the RS2 to NTRIP via mobile hotspot and then RS2 to Reachview on the mobile device via Bluetooth.

That worked but…
After deleting and recreating the SSID in ReachView, was able to reboot reach and it connected to the android hotspot and I heard the audible fix tone from reach. I also got a solid blue WiFi light on reach indicating that it was connected. However, at that point, I couldn’t get into the ReachView app because it couldn’t find my RS2. (There were no Reach units listed) I assume that’s because android made me turn off WiFi to use the mobile hotspot. Since there was no common WiFi, ReachView didn’t see the RS2. What a mess! I just need a good instructional video on connecting with an android tablet and sharing its internet connection with Reach. I can’t find one.

So are you trying to control the Reach from the same device that provides internet? From what I gather, it doesn’t seem so. In that case that second device also needs to connect to the android hotspot so it can find the Reach. If it is the same device, then there is something else going on. With my previous phone, I was unable to do both things at the same time (provide cell data and use Reachview) and you might be in the same boat. It’s frustrating but doesn’t seem to be Emlid’s fault as it doesn’t happen with all android devices.

In any case, a dedicated SIM card in the RS2 would make this problem disappear as using its hotspot should work fine.

To me it sounds like possibly a setting that is not allowing the Reach to get through the network to see other devices. Sorry if I missed it… what kind of Android device is it? What’s the OS version?

Finally got things to work, but not the way I really wanted it to.
Got it to work with iPhone hotspot turned on
Booted reach and it connected to iPhone hotspot
Connected tablet to iPhone hotspot
Connected Reach and tablet with Bluetooth
Set Reach to send position output through Bluetooth
Opened Field Genius and it wouldn’t connect to Reach
Set up new instrument profile in Field Genius with “no RTK”
Turned off mobile data on tablet and only then it connected and got a fix in field genius
At least it works! I can put it to work now…thanks for your suggestions Michael and Gabriel!


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.