RX Disconnecting from iOS

I’m having a terrible day trying to collect observations for elevation with my RX (1.3) connected to my iPhone (17.1.2). The RX keeps disconnecting in the middle of an observation. I don’t have this problem when working with my Mesa3 tablet running MicroSurvey FieldGenius. Please tell me there’s a solution that will reduce my field time spent fighting this technology.

1 Like

Hi Jared,

There is a newer firmware version of the Reach RX (1.4) that includes some internal fixes and improvements. Could you please try to update it with the Flash Tool and do a test?

Thank you! I wasn’t sure how to update it. I am having trouble getting the flash tool to work. It gets stuck at Device initialization 0%.

If this is the case, please try the following:

  • Use other USB cables.
  • Use other USB ports.
  • Disconnect all other devices connected via USB to your PC.
  • Use the Flash tool on another PC, if you have one.

What kind of machine are you using to flash? I was unable to flash on Windows 11 tablet and my corporate Windows 10 laptop but was successful with my personal Windows 10 PC.

Mesa3 tablet running Windows 10. I’m try my PC when I get back to my office.

1 Like

I got the flash tool to work on my office PC but the RX is still disconnecting.

Are you running App version 9.7?

Yes, sir!

Is your tablet on at the same time as the phone? Wonder if the BLUETOOTH connection is fighting each other?

It was not on when I tried it earlier. I have had that happen before though so I know what you’re talking about. I was near my truck which can fight for connection with my phone sometimes but it was off too.

1 Like

What version iPhone do you have? I’m new to this and I can tell you I fought issues with my phone connecting as well (iPhone 12 with the 17 update) then I tried my wife’s phone (iPhone 14) and it worked instantly with no issues. And yes, both phones had maximize compatibility on. I worked for about 6 weeks trying to get my phone to work and was super frustrated. Turns out I just needed a newer/different phone.

I have an iPhone 14 running iOS 17.1.2.

I worked with it again today and had no issues. I guess the problem resolved itself after another round of trial.

That’s great news buddy. Hopefully you won’t have anymore issues.