Rtkpost crashes before correcting reach RS+ base with Australian gnss data


First of all, I would like to say hello and express how grateful I am for this great forum. I have been reading here a lot of posts which were very useful!

I have been trying a lot and unfortunately nothing has worked. So I hope, it is rather a small mistake I am doing somewhere, and maybe somebody here is able to spot it.

As the title of the post says, I am currently having trouble with post-processing my survey data using rtkpost (64bit) for Win10;

I was in the field last year, using two Reach Rs+ units respectively as base and rover. What I am trying to do now, is to post-process my base station observation data with data from an Australian GNSS station ( Renner Springs in the Northern Territory; c. 85 km from my study site). I know the distance to the GNSS station is not ideal, but I hope to still improve my base station data as there were no reference points nearby.

My work flow is according to the reach tutorial and I also looked into several descriptions here in the forum. I use rtkconv to convert my base and rover ubx files into .obs, .nav. and .sbs files. I have tried different settings; Auto, u-blox, Rinex. As the PPK workflow (without a corrected base) worked well, I assume the error is not in this step.

I downloaded daily GNSS data from Geoscience Australia (ftp://ftp.ga.gov.au/geodesy-outgoing/gnss/data/daily/2019/) and use the software tool crx2rnx to convert the _01D_30S_MO.crx file to a .rnx file. Afterwards I use rtkconv to create an .obs file from it and when I upload it to a PPP service (Natural Resources Canada), I get a decent report (which brings me to assume the file is the correct one?!).

In rtkpost, I use the reach rs base station .obs files as Rover
I use the GNSS .obs file as Base Station
And I use the reach rs base station .nav file in the RINEX NAV,… section

I tried settings from the reach tutorial but also adjusted some according to posts here in the forum. I choose Static in the section Setting 1. Here are my settings:

As seen in my settings, I uploaded a Station Position file created with an online PPP service (Natural Resources Canada), but it also crashes when I don’t do it.

I apologize if the error I am doing is trivial and I hope that someone here knows what to do!

All my best,

Hi Fabian,

Welcome to the community forum! Great to know you’re enjoying it!

May I ask you to share your RINEX files with me so that I can take a closer look at them?

Hi Polina,

Thanks a lot for your response!

I was using the wrong gnss correction file. I think I have been able to find and unpack the right one (.o file) and used it to post-process my base station .obs and .nav files.

These are my results above! Now I am wondering how accurate this actually is? :smiley: On first sight it seems that the correction did not work very well as there are a few fixed solutions apart from each other. I am aware that the correction station is 85 km away, so I am not expecting a very high accuracy. But it would be really helpful (also for future use of our reach gear) to explore how accurate I can get in these conditions.

I uploaded my base station files and the correction file on dropbox:

It would be great if you could have a look and maybe have a hint or two for me.

As I understand, I need to extract a position from the (corrected) base station .pos file I created to use when I post-process the rover .obs and nav. files in a second step, right?

Thanks so much for your help!


Hi Fabian,

I have post-processed your data with the result of 69.5% of fix. Just set your elevation mask for 30 degrees and enable the SNR mask on 35 for both receivers. I’ll attach the screenshot.

However, please note that the baseline you’re using much exceeds the recommended one for post-processing with Reach RS+ (it’s 30 km only). I believe you can use the RMS shown in the RTKPlot as a general reference for an accuracy level, however, please note that the solution can hardly be accurate enough.

Would it be possible to find a closer mount point of your CORS?

You can also process the data with the NRCAN PPP service. Nevertheless, according to our user’s test, the accuracy it’s possible to achieve is up to 15-30 cm only.

You’re correct. You’d need to insert the found base position in the Base Station field of the Positions tab in the RTKPost.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.