Emlid

RTKplot mouse pointer differant to waypoint?


(Myozone) #1

I’ve just noticed that when I create a waypoint then hover the mouse pointer over the same point there is a discrepancy between the waypoint LAT & LONG and the one in the lower right corner ?

Dave.


(Christian Grüner) #2

As far as I remember, the point added to the waypoint menu is the center of view, not place of the mouse cursor or indicator?


(Myozone) #3

Hi @wizprod, Indeed, I was just wondering why when I hover the mouse over the location of that waypoint the location displayed in the lower right is different from that show for that waypoint, I was expecting them to be the same as they should be at the same location ?

To demonstrate I put the mouse pointer more or less at the same location as the waypoints LAT-LONG.

What I think it might be is a non-linearity error of some sort between LAT-LONG and the grid or when further away from the plot ‘coordinate origin’ ?

BTW all this is the BASE (ref pos) ~15.6Km from the ROVER


(Andrew Yushkevich) #5

Hi @myozone,

I’ve no success in reproducing your issue.
I set Coordinate origin as Base station and add Waypoint there.
After that, I set the largest possible scale, point mouse in the middle of base point and get the same result.

Here’s a screenshot:


(Myozone) #6

Hi Andrew, This happens when I add a POS file then place your mouse over the ‘base station 1’ point and look at the LAT-LONG in the lower right, it’s different to the one in the POS file. Also if you add the POS file’s REF POS as a waypoint you’ll see it’s different to the base station 1 location by about 750mm in my case (the referance staion is about 31Km away)
Dave.

Thinking about this some more, what I think it is, the POS file was created with another reference station that is using a different datum :roll_eyes: Scrub that, it makes no difference.


(Andrew Yushkevich) #7

Hi @myozone

A difference arises because even on the large scale it’s hard to hit the center of the point with a cursor.


(Myozone) #8

Indeed, I’ve just uploaded a video to demo the issue


#9

Have you tried deleting RTKplot.ini file?


(Andrew Yushkevich) #10

@myozone, as you can see, you didn’t hit the center of the point with ┿ at the beginning.
To do it, please:

  1. Add pos file
  2. Go to Edit - Options
  3. Find Coordinate Origin and set Base station
  4. Don’t move the map
  5. Go to Edit - Waypoint
  6. Add it
  7. Compare

You’ll see no difference :slightly_smiling_face:


(Myozone) #11

I followed your instructions exactly and all seems ok as you said. However, at the other end rover you get the same difference error. As I said before I think it’s a non-linearity error in RTKplot or something else ?

@TB_RTK Yep, tried and same error, but moving the origin as Andrew mentioned fixes it at one end with the other end still off - must be a quirk in RTKplot :man_shrugging:

Dave.


(Andrew Yushkevich) #12

Hi @myozone,

Can I ask you to make a video with this issue, please?
It’s a bit complicated to understand it through text and screenshots and I can’t reproduce it.

Thanks!


(Myozone) #13

Hi Andrew, Good idea I’ve just uploaded - A picture paints a thousand words …
Dave.


(Andrew Yushkevich) #14

Hi @myozone,

I’ve repeated all your steps from the video and can’t get the same issue.
The Average Point is still in the same right place.

Can I ask you to delete .ini file in the RTKLIB folder as @TB_RTK mentioned?

Do you still have the same issue after that?


(Myozone) #15

Hi Andrew, Thank you for the reply. I’ve tried deleting RTKplot.ini and also tried different
versions of RTKplot. It’s quite simply to replicate.

  1. Load into RTKplot the file attached.
  2. Place a waypoint at the base location.
  3. Change the Centre to base and the waypoint on the base has moved.

Dave.

raw_201811140535-A.pos (2.4 MB)