RTKLIB version 2.4.3 Emlid b27 and 2.4.3 Emlid Win64 b28 give different results on different Laptops

I have noticed something very strange and would like to ask if anyone has noticed something similar: The calculation with RTKLIB version 2.4.3 Emlid b27 and 2.4.3 Emlid Win64 b28 give different results when I calculate with the exact same settings in two different Laptop-CPUs. On an Intel Core i7 Laptop (Win10), the calculation with versions b27 and b28 gives exactly the same result. If I calculate it on an AMD A6-9225 Laptop (Win10) I get different results compared to the calculation on the Intel Core i7.

I’m desperate because I really do not know what I’m doing wrong.

I leave here the settings and raw data file and hope that anyone has an idea.

RAWDATA FROM REACH RS (newest update): RAWDATA.zip - Google Drive

Sounds fishy to me. There would likely be an output difference between software versions, but there shouldn’t be a difference between CPUs.

It would be good to try your test again in a sterile environment. For example, deleting the rtkpost.ini file. Also consider saving the options to file, and load the same options file on both laptops.

1 Like

Would 2nd what @bide is saying. Remeber to delete the ini-file first, or use the same ini-file transferred to the other computer. I have too many funky issues that requires deleting the ini-file, so wouldn’t trust it at all.

1 Like

Thank you for the fast feedback.
That’s exactly what I have already done. I always use the same RTKLIB on an external hard disk (versions 2.3.4 B27 and 2.3.4 Win64 b28).
I have tried both: The ini-files deleted before the calculation and reconfigured everything. And the infiles that are written in the calculation on the Intel Core i7 are taken directly for the calculation on the AMD laptop. I repeated this about 10 times.
But I will try again.
It can not be that the region configurations in Win10 play a role? The Intel Core7 is configured with a European layout and the AMD with a Latin American one.

Hi @raeichenberger,

It sounds strange.
May I ask you to share your .ini and config files?

Dear Tatiana,
yes it is strange and it really can not be. Surely I make a mistake, only I do not know which. Here is the last .ini file (I always delete this before a calculation and then load my default conf, so I have not the last .INI_and_CONF.zip (5.0 KB)
inifile of RTKLIB Win64). Additionally the two .conf files.
Best regards and all the best for the new year.

Hi Ralph,

I’ve tried to process your raw data using your config file in RTKLib v2.4.3 b28 on 2 different laptops, and the solutions were equal (they look the same as in your test on Intel Core i7).

It’s hard to say certainly what can cause the issue, and I’m afraid we can’t reproduce this. It looks like there is something with config files, as the solutions should be equal with the same settings.

Please let us know if this happens again.

I’ve processed the dataset on I7 and AMD A8-7600 and got the same results.I would verify your software versions. Because the images posted have different layouts. See attached image.

This is the photo above that you´ve posted.


Thank you Eugene.
Yes, it’s embarrassing, it seems like I actually messed up the software versions. I have now calculated everything again and also come to the same results (i7 and AMD). So I would like to apologize for the work that I have brought you. But thank you very much, the next time I check everything twice, before I post it.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.