RTKLIB on RPI2 with Navio+

Hello,

I have a RPI2 and Navio+. I can’t seem to get RTKLIB to work, specifically the obs counter isn’t increasing. I have tried following these instructions: http://docs.emlid.com/Navio-dev/rtklib/ using the rover-single.conf file for direct connection over spi and I have also tried following these instructions (RTK and Navio) using the navio-raw-rtk branch and rover-single-apm.conf. For the second case using telnet on port 12345 shows no messages. Using telnet on port 12346 shows messages from RTKLIB (although they have no position information). The robot appears in the correct position (although with a huge positional variance) in APM planner, connected over WIFI.

I notice there are also navio-plus-rtk and navio-rpi2-fixes branches. Could you please let me know which one we should be using for the RPI2 + Navio+ solution to get RTKLIB to work?

Thanks,
David

Hi David,
Please try to change the following in the configuration file:

file-cmdfile1      =../data/ubx_spi_raw_5hz.cmd

to:

file-cmdfile1      =../data/ubx_spi_m8n_glo_raw_1hz.cmd

That worked thank you.

Hi,

Are you able to have RTKLib and the AutoPilot code running to enable greater positioning accuracy in the Navio+

Do you think that the Navio+ would accept the positions from RTKlib?