RTKLIB : Can't process GLONASS in a GNSS solution


I am quite new to RTKLIB (1 week) but I am used to work with GNSS data. I am using a rover and a base station (who both measure and store GPS and GLONASS into rinex files) in RTKPOST for a kinematic solution on L1.

I can process the data with observation files (.o) and navigation files (.n) only for GPS data. Everytime I add the GLONASS navigation file (.g), the GLONASS satellites are not included in the solution.

I took time to select GPS and GLO in the Setting 1 page and to select ON for GLONASS ambiguity solution in the Setting 2 page.

I even tried all the combinations of .*nav , *.nav , *.n as suggested in the RTKLIB 2.4.2 manual.

What could I be doing wrong?


What version of Reachview, RTKlib ? And what format did you download from Reach?
Also som escreenshots of your workflow would help

I have the same problem :frowning: … Did you solve it? … I have an idea to make some mixed navigation RINEX (.yyp) But I have no idea how to make it from .yyg and yyn. Maybe some convertor? I already tried manually change theese tw files to one .yyp , but it did not work…

Do you have an example file to try?

Hi @autenticky,

If you have any test logs to try, please, share it with us.
It’ll make it easy to investigate the issue.

We also register this problem. Here I am attaching a session in which teqc quality control shows errors in GLONASS. Interestingly, that RTKPOST probably calculates it correctly. The base is virtual. RINEX with GLONASS is with zero XYZ. Postprocessing with the only GPS is OK.
Nisdkowa.zip (9.0 MB)

Thanks for the example, @r.pazus.

It’d be also interesting to look at @autenticky .yy* logs.

This problem was reported by the user of the Azus RTN receiver with the Reach RTK module. The problem is already solved. It occurs when in a static session we have the configuration: ‘Static’, ‘Continuous’ and GLONASS AR mode ‘ON’.
I recommended that in static sessions there were ‘Kinematic’ and ‘Fix and hold’ and RINEX in version 2.11. Then everything is OK.

If you are using rinex 2.11, you can’t use anything else but GPS and GLONASS, no ?

The teqc website is full of information. This example, which I’ve just introduced, shows that not only GPS and GLONASS are in RINEX version 2.11. Here in the example are GPS, GLONASS, SBAS, Galileo, and QZSS.

Ni-1_Quality_checking.pdf (75.4 KB)