RTK with VRS base, no access to the caster

after uodating to ReachView version: v0.4.9 it was impossible to reach my ntrip caster from the MLID rover. As I’m the manger of the ntripo caster I can monitor every guest which is trying to access the services but none is coming from the EMLID. Is there a way to check what rtkrcv is doing? I was able to acces EMLID throught ssh and I’ve a lot of exeprince with rtklib running on other devices (mainly with linux OS), as I can see rtkrcv is running (I’ve found it with the ps command) but thers no option such -p to give the user a telnet access to the rtkrcv server (useful to see all the running information of the running rtkrcv system). Thanks in advance for any help.


As a further clue I’ve activated inside the RTKLIB config the TCPSERVER mode on port 7777 but no process is listenining on that port, I’ve tried with the command netstat -tnlp | grep :7777 and I’ve had an empty string as result. Is it possible that something is not working after the EMLID update?

Everything works fine for me with NTRIP on 0.4.9, as you are connecting to a VRS, do you have “Send GGA position to the base” set to “single”?

How is Reach connected to Internet?

Hi Igor, thanks for answering,
strangely enough the config was working before the update, anyway:
a) “Send GGA position to the base” is set to "single"
b) Reach gets the acces to Internet throught a WiFi router. The WiFi router is enabled to give
Reach units always the same private ip adress: The router is set with a public IP address and al the TCP/IP traffic is routed between them. I’ve build some nat rules inside the router so I’m able to gain the accces to Reach also from outside the local net. Currently I’m able to enter the Reach web page from the public address and so with the ssh.

Hi Igor, probably I’ve found out the cause of the problem. I used to change the RTKLIB options without stopping the current running session. Something weired happens when I do that because the session automaticaly stops and when I start it again (start button in the Config webpage tab) MLID is not able to reach the caster. If I stop the current running session, I change a whatever parameter and then I start again the rtklib session everything works fine.
Anyway it will be nice to have the rtkrcv service run with the -p [telnet PORT] enabled. Do you think it will be implemented in the next versions ?