RTK online data processing with RPi

Hi, I’m working with a Reach RS and I want to use like an external GPS from raspberry pi without use ardupilot. The point is I need to read online, the current position of the system using UART protocol.

I configured the Rover module and the communication with the base (and it works), but when I try to configure the position output using UART, I cannot read any information from the RS module.


I’m working in an trajectory control for an autonomous system but I need a more trustworthy position system, because a traditional GPS has too much error.


Hi @Sebastian_Tilaguy_Le,

Did you make tests inside the building?
Can you show your settings in position output tab?
Also, can you share a screenshot with your UART output data if you have something in the stream?


1, yes and no, I made tests inside and out side.

3, In my laptop

In Raspberry Pi there’s nothing, I cannot see any information.

Actually, I tried the solution that you recommend here:

and it worked in my laptop with OS windows, but it hasn’t worked in the raspberry pi yet .

@Sebastian_Tilaguy_Le, can you describe your RPi setup steps?


So, I don’t use ardupilot, but I have the latest version of raspbian that is suggested in this link:

Also, I already downloaded the image and unzip it in my raspberry pi, I installed “dfu-util” too and in this point everything is OK.

The problem begin when I run the flashall.sh file, because when command window tell me that I have to connect Reach modul, my RPi never detect it.

I’m not sure if it is the information that you request me.

Hi, I was waiting for you answer.

Please I really need to finish my project.

Hi @Sebastian_Tilaguy_Le,

Can you show a photo of your setup?

You don’t need to install anything on RPi board with Navio2.

To get your position you need to connect Reach to Navio2 and set Position output as in your screenshot.
After that ssh on RPi and make screen /dev/ttyAMA0/ 115200 to test if you getting corrections.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.