RTK Inject with Mission Planner error

  1. Reach Image v2.3 and ReachView version v.2.6.0.
  2. When attempting to connect to GPS inject error message occurs

I am using Mission Planner 1.3.48.3 with APM copter V3.5.0-rc 10, on a Pixhawk 3dr px4.
3) Pixhawk and Mission planner is setup like stated in the ardupilot-integration portion of the Reach Documents.
The base is sending corrections over wifi into mission planner.
Radio telemetry is connected directly to the laptop running mission planner, set to a Baud rate of 57600.
Inject MSG type in not selected, neither is M8P autoconfig.
4) Here are some screen shots of some of the settings.

Base setting

Rover settings


Error

Rover still getting corrections data from mission planner

Hi,

Did you follow this guide?
https://docs.emlid.com/reach/ardupilot-integration/

Yes the guide was followed exactly as described.

So far we could only reproduce this behavior with base mode sending BeiDou corrections. Can you please send us screenshots of RTCM3 message settings and rtk settings?

I believe I have resolved this issue. I connected the Reach via serial port and used Mission Planner 1.3.45.

1 Like

I make a work-around for this problem

1 Like

Thanks, we appreciate it.

However, this PR do not really “fix” Beidou RTCM meesages problem. Mission Planner seems have problem parsing Beidou RTCM messages from reach. I am not sure is the problem from MP or reach?

This topic was automatically closed after 100 days. New replies are no longer allowed.