RTK df13 powering issues/ LED status clarification

I’m trying to power an RTK device over the df13 but I’m getting a led sequence that I cannot match to anything in the documentation (tried looking at the RS docs too, just in case). It goes through a sequence of white, blue and red.
I tried uploading a GIF but it didn’t display it properly so please excuse my attempt in describing the sequence below.

The sequence is:
time1 ______ time 2 _____ time 3 _____ time 4
white(flash) __________________________________
____________ blue-> __ (constant on) __ <-blue
_____________ red ________ red __________ red __

I am supplying it with a clean 5V and my setup should have 1.2A capacity. Monitoring the voltage drop whilst powering shows that the voltage stays steady at 5.1V. The current draw however fluctuates. The draw starts as a steady rise from 30-40mA to about 700-800mA over 3ish seconds. It then drops off a cliff to start at the same 30-40mA point.

I should also mention that powering over USB is fine. Everything running hunky dory then.
I’m starting to get tempted to butcher a usb cable and get the juice in that way… just don’t want to fry anything today.

Hi @snspinn,

It seems that Reach doesn’t get enough power. May I ask you to try another cable or power source?

Hi @svetlana.nikolenko,

Thank you for getting back to me.
I have tried a different power source but, no joy. I am powering it from a 5V usb to the df13 ports (I tried both). This is sufficient to power the device through the micro usb port so I reckon the issue is with the df13 port(s)?

I also having an issue with these ports when trying to get a serial stream from them which I have described in this post.

Given the age of the Reach unit, the circuits may have reached the end of their life. I would like to try installing the older firmware as final attempt but, as far as I understand, this isn’t supported?

If I happen to find a fix, I shall update and hopefully in the future I can find an excuse to break the piggybank for a new set :wink:

Thank you for your time.

Hi @svetlana.nikolenko,

I retract my latest statement. The microcontroller indeed seems to be incapable of supplying the correct amount of power consistently. Had to reinstall the firmware so that the issue wouldn’t repeat when powered with an adeqaute power source.

Now if the serial comms would work I would be delighted :)…

Thanks again from your help.

Hi Samuel,

If I get you correctly, is everything fine with power through the DF13 port now?

Yes Svetlana, I don’t know exectly why but everything is working well again. :man_shrugging:


Anyway, glad to hear you don’t have any issues :slightly_smiling_face:

Please, don’t hesitate to ask in case you have any other questions.