RTK corrections via Data collector modem

Hi Everyone,
I have two questions.

I have an RS2 with Oukitel WP6 phablet data collector. How can I use the phablet’s modem and data SIM card for NTRIP correction receiving, when I use the Reach View3?
At this moment, I have to use an external, other smartphone, which is a hotspot and provides the net. The using of the field phablet’s modem and mobile net would make the configuration easier and more fieldproof.

If I use the SIM Card of my RS2 for NTRIP, after approx. 2 minutes the RS2 interrupts the WiFi connection with my field contoller. After it, the two devices can not reconnect. The only solution is, I restart the configuration. But the story is the same: after 2 minutes the Wifi connection lost.
I have tested it more Android devices, but the results are the same.
In the other hand, If I remove the SIM Card from the RS2, this problem doesn’t appear, the Wifi connection is stable. Is this any RS2 serie bug?What’s the solution?

Thank, VBR; Sándor

1 Like

Hi @gpstakarok,

Thanks for the report!

If your field tablet is capable of using the cellular network and sharing the hotspot, it should be possible to connect the Reach device to it and configure it with the ReachView 3 app. The process of connecting to the device’s hotspot should be pretty similar on all devices. As an example, you can use this video where we describe how to connect the Reach device to the iOS hotspot.

Do I get it correctly that you no longer can connect to the Reach device via Wi-Fi connection? It’d be great if you could share the Full System Report from your device with me when the SIM is inserted into the unit and when there’s no SIM inside. Please send the report to me in PM or via support@emlid.com as it may contain sensitive data.

HELLO I HGAO D E THIS WAY BUY ME ONE OF THESE DEVICES TO TRANSMIT WIFI AND I HAVE NO PROBLEM

1 Like

Thanks for your response.
Does this solution work with Android operation system?
I will send you system reports about the mentioned two configurations, soon .
Thanks, VBR

In the Android device, I can not switch on the Wifi and the Wifi Hotspot in same time.

Put the sim card to the oukitel.
Then you have internet to the oukitel.
Then pair the rs2 with the oukitels wifi hotspot and you are done. No need for external phone.

1 Like

Thanks for your response.
How does this solution work with Android operation system?
I can not switch on the Wifi and the Wifi Hotspot in same time.

In the other hand, I have to update my topic: at this moment the RS2 doesn’t see the the hotspot phone. Only the “classic” Wifi modems are visible for it in the office. We try it more phones and out of the office, in the field too.

Only one mode works well: NTRIP via BT, with SurPAD appliaction, when the SIM card is in the Oukitel.

Normally you shouldn’t need more than the hotspot enabled on the phone. If the RS2 can connect to that hotspot, then phone will be able to see the RS2 in the app. If not, then something else is interfering. If BT is enabled on the phone, try disabling it when you are trying to connect. I have had that issue in the past with certain devices.

Thank you very much, I’ve tried it. It worked only once. It seem like the RS2 doesn’t or just rhapsodically see the mobile hot spots. :frowning:

I don’t have RS2 only M2. The M2 connects fine to any hotspot I have tried either phone or wifi router. The only glitch is that you must wait for the green led to be solid otherwise the RV2 or RV3 doesn’t detect the M2.
Generally the connection lags a bit but nothing terrible.

Hi @gpstakarok,

Would it be possible to double-check if the hotspot is broadcasted on 2.4 GHz? That’s the only frequency Reach receiver can work on.

Usually, you don’t need both enabled Wi-Fi and enabled hotspot on your Android device. To connect Reach to the hotspot on the same device, you just need to do the following:

  • Connect to the Reach’s hotspot
  • Open ReachView 3 -> go to the Settings -> Wi-Fi tab
  • Delete all known Wi-Fi networks
  • Choose Connect to the hidden network
  • Enter the credentials of your hotspot
  • Press connect
  • Turn off the unit
  • Turn on the hotspot on your device
  • Turn on the unit

The unit should be able to connect to your hotspot while turning on. You will see the network LED blinking blue and then becoming solid blue once it’s connected to your hotspot.

Thanks for your response.
I tried it. I think the problem is the RS2 doesn’t see neither Oukitel nor Lenovo hotspot. We tried a Samsung phone like hotspot and it worked well.
Unfortunately, the factory datasheets and descriptions do not state that even the type of phone needs to be paid special attention. :frowning:
In the other hand, I have Oukitel controller only and I have not Samsung phones…chess matte. :angry:

My second question was the internal GSM theme: the Wifi works well between receiver and controller, when I remove the SIM from the RS2. :confounded:
I got an idea that I try the 2.26 FW. Ok, maybe I will but this is a beta version. Have you any experience about it, how stable solution?

I have to say RS2 doesn’t see neither Oukitel nor Lenovo hotspot. We tried it with a Samsung phone like hotspot and it worked well.
Unfortunately, the factory manuals do not state that even the type of phone needs to be paid special attention.

Hi @gpstakarok,

The only requirement for the hotspot to work with Reach is that it should broadcast on a 2.4 GHz frequency. As the issues you’ve experienced are not something we’ve met before, we’ll need further troubleshooting to understand how to solve it.

Could you please specify if other devices connect to the hotspot of your Oukitel and Lenovo phones? Do you have other Reach receivers to check if they don’t connect as well?

Please check this behavior with the latest 26 Beta 2 firmware version. This issue should be resolved there. In case it’s not for you, please, share the Full System Report from the unit with me in PM. It will help us to identify the cause of the issue as the report contains a lot of configurational information.

Thanks for your response,
Yes, I’ve used 2.4 GHz Wifi, yes, in both of devices (Oukitel and Lenovo) this function is configurable (2.4 GHz-5 GHz).
Yes, I’ve tried with other field contoller: Stonex SH5A. The RS2 doesn’t see it. I’ve tried it n two ways: like external hotspot and like a “direct” controller. Yes, in this case the Wifi was in 2.4 GHz mode too.
I have to say, the RS2 is a very smart device, and your idea is very good, but unfortunelly doesn’t work too well without 3rd party solutions (eg.: SurPAD via BT).

Hi @gpstakarok,

Thanks for the details!

Could you please share the Full System Report from the unit with me in PM or via support@emlid.com? This will help us to see the possible reasons for such behavior and investigate this behavior.