RTK and Navio+

Getting the rover switched over from Navio RAW to Navio+.

The only question I have is the RTK component.

  1. which RTKLIB repo should be used to ensure that the -E switch works with the Navio+

  2. The Navio+ ublox chip will send proper messages to RTKLIB as did the “6” model in the Navio RAW?

  3. any other changes to the config for using Navio+ board in place of Navio RAW board for doing RTK?

1 Like

@timkaiser

  1. You can use [navio-plus-rtk][1] branch. Do you use RPi2?
  2. It’ll send other messages. More particularly - TRK messages. But RTKLIB processes these messages as you might’ve expected.
  3. The only thing you need to adjust is file-cmdfile1 option to …/data/ubx_spi_m8n_glo_raw_5hz.cmd

Please let me now, if these fixes don’t work as is.
[1]: https://github.com/emlid/ardupilot/tree/navio-plus-rtk

@staroselskiy

Thanks for that - I will try it. However, there is no ubx_spi_m8n_glo_raw_5hz.cmd file.

There is a ubx_spi_m8n_glo_raw_1hz.cmd file, though. What parameter do I need to change in it to make it 5hz instead of 1hz?

Thanks.

T

@timkaiser
I’m using the Ublox NEO M8N over USB, there I get about 10 Hz RAW Data. But I have to disable SBAS and NMEA output, and output to all not used peripherals (in my case UART,SPI and I2C) and I need a higher baud rate (about 230400). These configurations could be done with the u-center.

I don’t know If it’s possible to get 5 or even 10 Hz over SPI but you could try it by adding one command to the ubx_spi_m8n_glo_raw_1hz.cmd:

for 5 Hz you could try to add this command:

!UBX CFG-RATE 200 1 1

for 10 Hz you could try to add this command:

!UBX CFG-RATE 100 1 1

@timkaiser

I just realised that you don’t need to adjust RTK config since all the configuration is done by APM.

Sorry for the inconvenience.

@No_Peppermint

You disabled only SBAS and NMEA? What about GLONASS? From my experience with NEO-M8N the rate dropped to 1Hz when GLONASS was enabled.

@mikhailavkhimenia
GPS and GLONASS enabled, SBAS and NMEA disabled
All unused peripherals (uart,spi,i2c in my case) disabled
I can not confirm exactly 10 Hz since I am using rtknavi at the moment, there is only a flashing green rectangle, but with the CFG-RATE config. it’s flashing faster :wink:
There are other people in this (german) Forum http://www.gpsforum.geospector.de/phpbb/viewtopic.php?f=3&t=3503&start=15 who also get more then 1Hz RAW data from NEO-M8N

@No_Peppermint @mikhail.avkhimenia

Back to work.

With rover-single-apm.conf loaded in rtkrcv, no obs() counter is ticking.

??

@No_Peppermint
I used two ublox m8n with rtknavi. and get 5hz data, gps and glonass enabled. and i set output solution with serial type and nmea format. After it got float quality, I get nmea sentences by connecting serial port, but the position and velocity are not correct. however, rtknavi can plot the position correcttly. This only happened in the m8n navigation rate larger than 1hz.