RS3 Fail to connect to saved wifi

Hi everyone, i have an issue that doesn’t appear every time, but quite often. RS3 doesn’t automatically connect to saved wifi network. The problem occur 100% times when i’m at home and RS3 recieve dozen of wifi network.
To re-connect RS3 to the wifi, i need to forget that network and add it again.

I have 2 hotspot devices, a Huawey Key, which is my primary network device, and the Iphone 15 pro max (lastest ios firmware) as backup. With both of them after first connection, RS3 fail to connect. In the field, if there’s no other network wifi source, sometimes can connect automatically, but when i’m near lot of wifi sources, like at home, the available wifi list doesnt’ show my pre-configured wifis, and if i try to connect one of them, it give me error.

This is the typical field situation: Huawey key with Surface pro 9, RS3 and DJI RC + connected.

Here i have also the RS3 on, without connection

In this screenshot, both Huawey key and iphone hotspot was on.
If i want to connect, i need to forget Huawey_Key network, after that the network appears in the available source and i can connect without issue.

Other devices (Iphones, laptops, remote controllers) connects to the Huawey hotspot (or iphone’s hotspot) without any issue. Huawey key device limit is 10, so it’s not that limit.

Any solution to this problem? any settings to improve?

Hi @alessio.bonfante

Welcome to the community!

Are you using the latest firmware and app versions (RS3 31.8 and Emlid Flow 9.10)?
Is the hotspot security set to WPA2?

Can Reach connect to Wi-Fi on startup if there’s only 1 available saved network?

For connecting with an iOS device I recommend trying to use a Bluetooth connection since it is easier and faster! Once connected via Bluetooth, Reach will still receive corrections if there’s Internet access on the mobile device.

Some of these steps might be helpful to check when connecting Reach to iOS Wi-Fi:

  • iOS device is not connected to any other Wi-Fi networks. (The hotspot may drop once your iOS device finds an available Wi-Fi network and connects to it).
  • Enable the Maximize Compatibility option on its Personal Hotspot page.
  • Keep the Personal Hotspot page on the iOS device open while the Reach is loading.

Keep me posted on how it is going!

Hy Merryana,
yes i’m using last firmware on both devices (yesterday update to flow 9.11).

Keeping 1 only saved wifi network seems to work, in the field away from tons of wifi network.
If it has both saved network (and 1 only transmitting), it doesn’t work, but after forgetting the iphone’s hotspot, the Huawey key looks to work properly, with automatic connection every startup in the field.

Not at home, like the wifi list could not have more than 5 or 6 wifis.
My huawei key is pretty basic, but it has never had any issue with other devices.

I cannot change the security protocol, but i think is WPA2, because when i check the infos in the emlid app, it says WPA2 for security:

Inside the house i cannot now in any way connect to that wifi.

As you can see, pc and other devices sees the network, emlid not

Maybe the “underscore” in HUAWEI_KEY is the issue? Maybe try a simpler wifi id name to test? i.e. just HUAWEI

Hi Alessio,

Have you tried to change the network name from HUAWEI_KEY to HUAWEI, as @timd1971 mentioned? I’d also recommend checking that the Wi-Fi passwords are as simple as possible.

In this case, could you try to add the Wi-Fi manually (+Add a new network) and let me know if it works?

If the issue persists, to help us investigate the case, please send the FSR to

Hi Merryna, no, there’s no way to let the Huawei key to work. I tried everything, simplify the name, simplify and then remove the password, but nothing.
Now it’s 2-3 days i can’t connect at all, the wifi are not visible.

Must be fault of the Huawei key, with some sort of incompatibility, because with other wifi and mobile hotspot it works. It’s a pretty easy key, i cannot set the password criptography, maybe the issue is related with that.

The key is a Huawei E8372-153, it worked like a charm with every other device i’m trying to send internet connection.
I’m about to buy another mobile hotspot, from D-link, hoping to be more lucky.

I’m sending the FSR. Thank you

1 Like

Hi everyone, I’ve managed to let it work (or at least after this change tonight seems to work 100% of times.

The Huawei key has an app to set it up, throug HUAWEI AI LIFE. In this app you can set most of the settings about the wifi network, but tonight I’ve discovered that if you try to access the key’s settings throug web browser instead its app, there’s more and more settings to play with.

Everything was OK, except for a Firewall option in the system settings that was on, and I’ve never know there was.
Tried to disable the firewall (don’t ask me how a Firewall can impact over wifi SSID visibility…) but after that the wifi network is visible in Emlid RS3 settings, I can save the network and it can access every time on startup automatically.

I’ll try to be sure tomorrow, but now it’s 5 to 5 connection without issue.
Seems problem solved!

Hope to help someone with same issue in future :slight_smile:


I hope last update… Tried this morning and of course… it didn’t work :frowning:
Don’t know why but wifi wasn’t recognizable by Emlid.

So i’ve done just to try a full key reset, deleting everything and then assign Static IP to every device connected:

It worked… for a while, then again same issue.
I’ve noticed that the issue persist after X time the key is on. Indeed i’ve found a “workaround”, and it worked 10 times out of 10 till now: turn on the Huawei key, and as soon as the wifi starts (the wifi led status turns on), turning on the Emlid, so it could connect as soon as the wifi is transmitting.

Waiting couple of minutes after wifi is on, means the emlid could not connect properly (while other devices can), it doesn’t see the wifi network at all, and i cannot either force to connect in the wifi settings.

Hope this workaround could fix the issue forever… I’ll let you update!

1 Like

Ok, finally THE SOLUTION! Yesterday after my post, after few hours, the issue comes back again. So I’ve asked myself what can cause a wifi network to work properly in a small amount of time, but if waiting few hours the network becomes invisible, so something has changed.
The answer was WIFI CHANNEL.
At every startup the router select the most free channel to transmit the data, so it’s easy that in a small amount of time, with same networks around, it select the same channel. Waiting hours, networks situation changes, so it could change the transmission channel looking for the most free frequence.

I’ve download a wifi analyzer and I’ve looked at the channel the key was using when I can correctly connect to emlid, first working channel was the number 5.
So I’ve forced the key to transmit in that channel et… Voilà.

Emlid is connecting properly since last morning, I’ve done more than 15 connection test during all the day.

I think the Reach has some issues with wifi module, maybe is more sensible to noise (but my issue appears even in the middle of nowhere, without other wifi network), or simply it can connect properly in some wifi channel.

My next step could be to identify the working channel and which not, to confirm my thesis… But I’m a bit worried, once a thing works, don’t touch it :joy::joy:


Hi @alessio.bonfante, thank you for the update and for sharing your case with this community. I am glad to know it works!

Firewalls and some network settings can indeed cause connection issues. Some adjustment to the network setup is needed to make it work.

Based on the information that Reach can connect with other networks smoothly, it seems like the network setting as mentioned.

We received your FSR. We will look at it. If we notice anything unusual, we’ll let you know.

We’ve reviewed the FSR that @alessio.bonfante forwarded. There seem to be no issues with how the device interacts with the Wi-Fi networks.

It looks like the issue was purely on the network’s end. Everything should be working stably now.