RS2 wont reconnect to iphone hotspot after power cycle

I have been using the RS2 with ntrip subscription, I wanted to setup the RS2 so it could use a iphone 7 hotspot to get data connection and also use the iphone for reachview.

Following the instructions, using three devices I connect to the RS2 hotspot via device 3 and use that to set the wifi connection to connect to the hotspot the iphone is broadcasting.

The RS2 initially connects to the hotspot from the iphone and works perfectly, receiving ntrip data etc.

But it only works for that first connection, when power cycling and trying to reconnect the rs2 wont connect and just ends up making its own wifi hotspot as normal. I have tried every configuration of turning the iphone hotpsot on and off and rs2 on and off in various orders and about 1 in every 20 power cycles it will connect. But mostly doesnt.

It is really frustrating as I just want to be able to turn on and go. I have tried updating the reach and also different iphones and have similar behaviour.

Any suggestions?


Remember to enable the iPhone hotspot just moments before you need it.
iOS seems to disabling it quite rapidly, if not used.

Thanks wizprod, I tried this and cant get it to latch on correctly. Multiple attempts at restarting the reach and creating the iphone hotspot at various points of the reach boot cycle doesnt produce reliable results. I am sure its something to do with the way the iphone creates the hotspot but cannot figure it out :frowning:

What firmware are you running ?

Hi @hairyape1,

You’re right, the process of connecting to the iOS hotspot might be a bit tricky. As Christian said, the iPhone turns it off as soon as you stop using it.

I noticed that you need to keep the Hotspot page in the iPhone’s settings open while you’re trying to connect to it. May I ask you to try this method?

A post was split to a new topic: Difficulties with connecting M2 to iOS hotspot

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.