RS2 with Iphone

I have been through the Reach and Reach quick start guides a bunch.

  1. Latest firmware for both.
  2. If this is not a known issue I’d be happy to attach one.
  3. Detailed description given.
  4. Step by step actions given.
  5. Picture of set up is just the Reach RS2 and and iPhone
  6. RS2 and and iPhone X

This is the post here:

I have the RS2 and an iPhone. If I am at home I can connect the RS2 to the home wifi and then the iPhone app to the same wifi and the RS2 connects to the NTRIP service fine.

When I am in the field I can connect the iPhone app and the RS2 but can not connect to the NTRIP.

I read the documents a bunch of times and there are all sorts of iPhone options to follow but I am starting to think there is more to this story.

My iPhone says it doesn’t support the RS2 blue tooth device. So if I install a sim card into the RS2 will I then be able to use the iPhone with the RS2 or will I need to get an Android phone as well. Or if I just get an Android phone and no sim card for the RS2 will that work? And if I need a sim card I get the impression from some posts that a special sim card is needed such as a 3G or something. The docs just say put a nano in there. I need a special type of nano?

Also, if this is the case, the documentation does not state that anywhere I can find…


I know nothing about iphones but will caution you not to just go buy an android phone and think your problems will be over because they will not. Older android phones work perfect but newer may or may not. Android version 7 works perfect my android version 9 does not see the RS2 and makes me use the web browser to connect. But if I launch a hotspot from the android 9 version and the reach rs2 connects to it then the android 9 sees the RS2. At first I bummed thinking I needed to carry 2 phones but have figured out little ways to make version 9 work.

Thank you for the help.

It appears that the Reach is not able to work with an iPhone X at least because the iPhone does not allow a bluetooth connection with the RS2. It see it, you can even approve the connection, but then it is rejected because of being an unsupported devise.

OK, so I installed a sim card and the RS2 will now connect to the NTRIP network and I can use the ios app to pull points.

So really I have a simple question, is it possible to work in the field with the RS2 and an iPhone X without having to pay for a sim card and the associated monthly plan cost?

If that is the case then at least I know I am doing something wrong.

Yes, you just create a hotspot on your iPhone, and have the RS2 connect to that.

However, having a sim-card installed is a much smoother solution, in my opinion.
Can’t you get a subscription, where multiple SIM cards are just a one-time-fee?

1 Like

If the RS2 would connect to the iPhone hotspot then it might be possible to avoid the sim card. My problem is that the only method I have of setting up the RS2 to connect to a hotspot is to be connected via wifi to the iPhone, which then can’t broadcast the hotspot without losing the wifi connection. I can’t configure the RS2 for the iPhone hotspot without it seeing it first and allowing me to input the password. Grrrr

But you can :smiley:
Just enter the SSID manually, along with password and encryption options. Then click connect, and quickly start the hotspot on the phone.

1 Like

Wow! That worked easily. I feel so stupid sometimes. Thank you for your help.

NTRIP won’t connect if the RS2 is hotspotted through phone via WiFi and the Bluetooth connection is not accepted by Apple so that is not an option, at least not on an iPhone X.

Doesn’t seem to be any option but to use the SIM card. That works fine. Not sure what I could be doing wrong.

System Report:

Simple system report
app version: 2.20.6-rs2-rc0-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip:
  is_added: true
  is_connected: true
  is_visible: false
  mac_address: B0:F1:EC:02:17:2A
  security: wpa-psk
  ssid: MusicRoom
  uuid: 43202de6-3a5f-4567-8f43-57b602b4f2a8
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
    enabled: false
    format: rtcm3
    path: tcpsvr://:9000#rtcm3
    type: tcpsvr
  rtcm3 messages:
      enabled: true
      frequency: '0.1'
      enabled: true
      frequency: '1'
      enabled: true
      frequency: '1'
      enabled: false
      frequency: '1'
      enabled: false
      frequency: '1'
  discoverable: true
  enabled: true
  pin: '***'
correction input:
    enabled: true
    format: rtcm3
    path: avd70-1:***@
    send position to base: single
    type: ntripcli
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
    format: RTCM3
    started: false
    version: null
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
    format: UBX
    started: false
    version: null
    format: LLH
    started: false
    version: null
  air rate: 2.6000000000000001
  frequency: 868000
  output power: 20
position output:
    enabled: false
    format: nmea
    path: bluetooth
    type: bluetooth
    enabled: false
    format: llh
    path: :9001
    type: tcpsvr
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
    enabled: true
    format: llh_ext
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: true
    galileo: true
    glonass: true
    gps: true
    qzss: true
  snr mask: '35'
  update rate: '5'

NTRIP will connect if the RS2 is on the iPhone hotspot. NTRIP won’t connect if the iPhone is on the RS2 hotspot. I know because mine is now connected via the iPhone hotspot and it is correcting. I just tried it after wizprod explained how to connect to my iPhone hotspot. No Bluetooth connection is necessary but it is still available for connecting to my tablet with FieldGenius. This is the setup I was expecting when I ordered the RS2. Just couldn’t get it all together without using a separate hotspot until tonight.


Hi Dave,

To provide your Reach RS2 device with the Internet, you need to connect it to iPhone hotspot, not connecting the iPhone to Reach RS2 hotspot.

This guide explains how to do it in details.

No, I tried that a bunch. The online manual was the first place I went. I hot spot other devices to my phone all the time. I can’t get the Reach to do it. I’ll post all the screen shots later today.

Hey DaveB. I had that frustrating problem also. Tried a few times to connect to my iPhone7Plus as a hotspot. I had to manually add the SSID as it wasn’t picking up on it. I can’t say for sure but my password for the hotspot feature had a symbol. I changed the password to have only numbers and letters and got it to work first time. WORKFLOW. Turn on RS2. I used my iPad Pro and connected to the RS2’s wifi network. I turned on my hotspot feature on my iphone. I used the ReachView app on the iPad and connected to the RS2. I added my hotspot in the wi-fi menu. It then showed as available and I tapped it to connect. I showed a connection to my hotspot (blue bar at the top showing 1 connection) I then completely shut down the app. I connected my iPad to the hotspot (confirmed by the blue bar at the top showing 2 connection). I then opened the ReachView App and saw the reach unit (different ip address than the first time) and then connected. After configuring the NTRIP information for my CORS service it connected and I began receiving corrections. So, I found the trick to be two fold. One was to change the password to numbers and letters only (maybe?) and the other is using the iPhone as the hotspot and only the hotspot, I use the iPad with the Reach View app as the “data collector”. Hope this helps.

Yup the trick was to use a third device like an iPad. They don’t talk about that in the manual!


1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.