RS2 will not connect to Emlid Caster


I cannot get my RS2 to connect with Emlid Caster, it shows offline.

I had this working before and this is a new problem.
Also while I cannot get it to go Online, I did move my RS2 to a new place and tried it again and it did work. But now it is not working again. This may be a hardware issue since it worked fine before, and yesterday it did not work at first, I moved to a new location and then it did work.

I do not think this is a hotspot router issue since it did work before, worked once yesterday but now will not work. I tired different hotspots, and a different Mount Point.

I am open to all suggestions.

Thank you in advance.


Yesterday I had the same problem that you mention and another colleague from another province too.
both RS2 using stable version 29.2

1 Like

Some more information is:

I am using the newest non-Beta stable firmware 29.2.

Edited for Update.

I tried to reset the settings to default. No change.

I next put in a T-Mobile simcard. T-Mobile does not have 3G anymore in my area. Using 2G my Mount Point went to Online. I took out the simcard and then connected the RS2 to my hotspot and it immediately went to online.

I turned everything off and tried from the begining at all worked.

I tried again and turned everything off, and then back on and I am back to unable to get the Mount Point Online.

Another weird thing is that when I am connected to the RS2 and tried to turn off the unit from the app, it takes two times for it to turn off.


Yes yesterday y have the similar problem, in the web of Emlid Caster online 1/10 connected but the Rover never green receiving data, reboot the Base and wait other 5 minutes to average single after that te Rover FIX

1 Like

Today, I again tried to send out NTRIP corrections.

I was unable to get my Mount Point to go Online.

I tried 3 different Wifi sources with my base. Hotspot, Phone Hotspot and home internet.

I tried to put the T-Mobile simcard in the RS2 and this did not work today, although it did yesterday even with only 2G.

Even though my Mount Points had worked previously with the hotspot and phone hotspot I used Port Trigger to open 2101 on my home internet and on the Hotspot and this also failed.

The funny thing is this is intermitent in that I was able to get my Mount Point to go online once yesterday and once a few days ago.

I am truly confused right now and out of ideas.

I know I will have to wait until Monday to gain some insight as it is Orthodox Christmas right now, so Merry Christmas to our Emlid friends!

I found my solution, I had to. I need the RS2 for a project that is now overdue.

I reflashed the firmware with 29.2.

I used the Reach Firmware Flash Tool and reinstalled the firmware.

The directions are good.
The only thing I can add is that for me I had trouble with the step going into firmware mode.
It worked for me when I had the USB A to USB C plugged into the RS2 with the Firmware Flash Tool running and showing the helpful video example, and I had the RS2 on then turned it off, then held down the power button and plugged in the USB A to my computer. When I tried where the RS2 was already off it did not connect, so for me it worked with have the RS2 running with the cable at the ready, turn it off with the power button, release the power button, press and hold the power button look for the lights and plug the USB A into the computer.

From there is was a matter of waiting.

I tested the Mount Point going online 3 different times from all hardware being completely off and I would then also go back and forth connecting to my Hotspot and watching my Mount Point go Online, Offline, Online etc.

This is why firmware updates always scare me with anything.


It is not the solution ! Let’s wait for an answer from Emlid after the holidays. I’ve been working with RS2 for 4 years and I never had the need to do a reflash

Just a note regarding re-flashing a firmware. It is rare, but sometimes re-flashing will fix a problem because it can be more comprehensive than over-the-air incremental updates.

I’m not saying that is the case here. But sometimes with incremental updates, a module in the firmware gets skipped where as with a re-flash, every module is replaced with the flashed firmware.

1 Like

agrimgalina I took off the Solution button.
This did not fix it. I am at a loss now.
Last night after the firmware reflash it worked every time (3 times).

Today I went to try and start my project and I could not get my Mount Point to go Online.
Nothing changed from when it was working last night.

LoRa worked fine, but for this project I cannot use control points as the area is too dangerous to enter and RTK data to my Phantom 4 RTK was the only choice.

My RS+ (Rover) was shown Online but I could not get my RS2 (Base) to connect to the Mount Point.

I guess I will wait until Monday. This hurts as I have 2 projects on hold, and have 4 large projects coming up and the NTRIP to my Phantom makes these possible.

1 Like

Maybe give 30b3 a try. You can always drop back if it doesn’t help.


Some more information on my issue.

Last night I used my home wifi to attempt to get my Mount Point to go Online.
I used my Asus router which has an excellent application to Port Forward 2101, this did not work.
I can see that my base is sending and receiving in the Asus application.
Again I tried my home Wifi, my hotspot and my phone’s hotspot. I also tried different Mount Points (a, b, c, d). I was unable to once get any Mount Point to go Online.

My RS+ rover though did go Online in the Rover section and did so on my hotspot, my phone’s hotspot and my home Wifi.

Local NTRIP did work using my hotspot and again with my phone’s hotspot.

I also have a problem where when I use Emlid Flow to turn of my RS2, sometimes it works on the first try and sometimes I must turn it off twice before the RS2 shuts down.

1 Like

I have seen other users reporting this issue in other parts of the forum

Hi there,

The issue was resolved during the troubleshooting via email.

If someone faces something similar, don’t hesitate to create a new thread or contact us via email.

1 Like