RS2 wifi problem

The RS2 wifi hotspot runs for a few minutes and then ReachView (both versions) disconnects. I still see the network, but I can’t connect to RS2 (can’t see it) or if it connects it disconnects immediately. Now I have the v26 beta 1 firmware version, but I also tried with 2.24.2 and I have the same problem. I tried with 8 android phones versions between 8 and 10 and they all have the same problem. At the moment I can’t use the receiver at all.

Hi @amc.proiect,

Do I get it correctly that it’s possible to reconnect to the receiver after it disconnected? Is this behavior repeatable with any external Wi-Fi network?

It’d be also great if you could share whether you have a SIM card inserted in your Reach device while the disconnection happen.

I managed to reconnect twice only for a few seconds. After the connection is lost, I see the network but I do not see the device.
I can’t connect to an external network because I can’t set it up.
I have a sim inserted all the time. I didn’t have any problems until I made the last update.

Thanks for the comments! Would it be possible to take out the SIM card and check if it makes any difference?

I removed the SIM and it doesn’t seem to cause any problems, but I can’t make measurements either. Usually after a few measurements it disconnects.

Thanks for the test!

Could you please connect the receiver to an external 2.4GHz Wi-Fi network and check its behavior? You can do it by changing the network via the Updater page, for example. To access the Updater page, you just need to insert 192.168.42.1:5000 to your Internet browser while being connected to the Reach’s hotspot.

It’d be also great to check the Full System Report from the unit. Please share it with me in PM or via support@emlid.com as it contains some sensitive information.

I connected to a 2.4 network but I don’t see rs2. probably as it is from the router settings

Without sim it works ok, but when I mount sim it doesn’t work anymore

Thanks for the system reports! We’ll take a look at them.

Do I get it correctly that you can’t open an Updater page when the SIM is inserted? Please check if the behavior continues with any other SIM card.

Just wanted to quickly add: do I get it right that the issue is present both on stable v2.24.2 and beta 26.0.beta.1 firmware versions?

Hello,
I changed the SIM card with a new one and the problems are the same.
I can’t upgrade with a SIM card (it never worked). It reaches the page and then it doesn’t work anymore. For the upgrade I have to connect to a wifi network.
I have the same problem in both versions v2.24.2 and beta 26.0.beta.
When I first upgraded to v2.24.2 it stopped after 10 -15 minutes but then recovered. In the last week it only lasted 5-10 minutes and then I had to restart RS2.
Now it doesn’t work with the SIM card at all.

Thanks for the explanation! We’re currently checking the logs you’ve shared. I’ll be in touch once there’s news.

some news ?

Hi @amc.proiect,

Sorry the process takes long! We’re still looking into it. I’ll contact you once we have an update.

Hi @amc.proiect,

Would it be possible for you to try SIM cards from different mobile operators? This test will help us to understand if there are special settings for the specific operator.

Also, please, check the connection with the mobile data sharing option switched off. Does it make the connection more stable?