RS2 Stuck Booting

At first startup I did the update. Upon completion of downloading, ReachView showed the update was installing, but went into a continuous scrolling battery led loop (this lasted about 10 minutes initially before I tried resetting it). I have tried turning on/off numerous time, have doe a few hard-resets, and every time I turn it on the battery LEDs just scroll in an endless loading loop. It connects to WIFI (multiple different ones that I initially set it up on.

I have a project this weekend to use it on. Any feedback is greatly appreciated!

Hi Brian,

Please contact us at with the device Serial Number and order date and number.

You can get the Serial Number by scanning the QR code under the SIM card slot.

Also, since you can connect to Wi-Fi, could you try opening the updater page in the address bar (Reach_IP_address:5000) and, if it’s possible to access it, send the screenshot of the updater to us? It helps us to check whether Reach fails any tests or not.

Thanks Tatiana, I submitted an email to support. I don’t know what you mean by open the updater page in address bar (Reach_IP_address:5000).


Thanks! We’ll be in touch soon.

If the Wi-Fi LED is blue on the device, it means it’s connected to Wi-Fi. You can connect to the same network using your phone and do the following:

  1. Open RV3 and check if the unit is listed there
  2. If RV3 can discover the unit, it should show its name along with IP address (it may look similar to this set of numbers:
  3. Open any browser on your phone and type in this Reach’s IP address and 5000 port with a colon between them (for example, this way:
  4. It should open the updater page

Please let me know if it’s possible to access this page on the unit

The device is not recognized when it’s connected to wifi. I have even removed it from WIFI area and connected to the reach wifi directly to my mobile device, and it still doesn’t recognize the unit in the ReachView or ReachView 3 apps.


When it’s in hotspot mode, it has a defined IP address. If the Wi-Fi LED is white and you can connect to Reach’s network, you can try opening the in the browser

Hi Brian,

Thanks for checking. I’ve received your email. Please let’s continue the conversation there since further investigation may contain sensitive info.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.