RS2 receiver keeps disconnecting from android phone (emlidflow)


Since I last used our pair of RS2 units 6 months ago (base + rover for RTK), my android phone has been upgraded to a newer model and the reachview3 app seems to have been renamed to emlidflow. Everything worked smoothly before, but now, the receiver loses the connection (despite still being on the wifi hotspot) while I travel in between every point I am surveying (only 1-3 minutes between points), forcing me to refresh the receiver list and reconnect. It is annoying, but I am still able to complete my work. Any idea what might be causing this issue?

thanks in advance

Hi Daniel,

Thanks for reporting!

Can you please check if the Battery optimization setting is disabled for Emlid Flow? When it’s enabled, it may induce disconnections.

1 Like

Thanks Liudmila, i have turned it off and will test it. I have concldued that it seems to be a phone problem. If I keep the screen open to the emlid flow app, there is no issue, but as soon as it screen locks I lose connection.

Sure, please let me know how this works now! This setting should help based on the behavior that you described.

Hi again, I can confirm that your suggestion fixed the problem. Thank you so much.

1 Like

You’re very welcome!