RS2 PPK Post Processing RINEX Files?

Hi,

I am using the RS2 to log files and the processing software I am using from BAAM Tech uses RINEX files to process and geotag photos.

When I try to get the event positions from the BAAM Tech Rover on my P4PV2 and the base station Emlid Reach RS2, I am not getting a populated CSV. I tried to match them using RTKLIB as well, and its not working. I am just not sure if I am even collecting the data properly at this point?

The Rover from the drone saves a .sbp file that is supposed to go into the software and the RS2 base station, I have logging 1 second intervals of RINEX 3.03 files (.21O, . 21B & .21P).

When I go to put the data into the processing software it keeps asking for .obs files? But the RS2 isn’t even saving that file format for me?

Super lost, can anyone help me out?

1 Like

Just rename the .21O to .obs

The contents are exactly the same.

2 Likes

okay great to know!

thanks!! do you know of any way I can visualize just the base station RS2 Rinex/OBS file to verify that it collected points? The size of the file implies that there is data there, but it isn’t working with the Rover data I am collecting. I just want to make sure that the RS2 data is valid.

Well, provided you don’t actually want to interpret the data with your brain (as in doing the calculations on the raw data), you can verify that there are observations for the entire period just by looking at the file in a text editor like Notepad++. Rinex is a plain text format. In the header, you’ll see start and end times in UTC, and in the data section, you’ll see each epoch (the time at which a data point was recorded) listed throughout.

1 Like

that was super helpful! I think I figured out the reason why the base file and the rover file werent matching up! When I looked at the notepad and looked at the data, I think that the dates are wrong on the rover. Does anyone have any suggestions on how to change the data collection date on a rover that is attached to a P4PV2?

Also is there a way that I can load just a single .obs file to either RTKLIB or a different software to visualize where the point is? Or would I just do that in something like Arc Map?

1 Like

Most commercial PP software packages will show a scatter plot of each file, base or rover. I believe that your software would do the same if you are familiar with it. I haven’t used RTKLIB in a while, but I believe it will do the same for unprocessed point files.

This should not be possible. The way GNSS works, it gets the current date and time from synchronizing with the satellites as it receives their signals. If both units recorded at the same time, their periods should match.

The question now becomes: are you trying to post-process a drone track with a base that wasn’t recorded at the same time? If yes, then there’s your problem. You can’t post-process if the observations weren’t done concurrently. Aside from flying again, the only other solution is to try to get observations matching the flight from a continuously operating reference station (CORS) that’s not too far away.

For the second question, the simplest way, in my opinion, to get a quick position for a single point, is to submit the observation to a PPP service (like NRCAN’s). It will be post-processed (with various precisions depending on how much time has passed between in the field and in the office), and you will get a position file for every epoch in CSV format that you can then load in a GIS suite.

1 Like

Is there anyway you could help me with this? I have a RINEX file for my base station and OBS file from my rover that are fine with date and time match up but it still not creating an event position csv file when I put it through the BAAM tech software or RTKLIB.

Base Data: https://drive.google.com/file/d/1716DTbYypzY3Bz7ILIbm7BnmVtd6TZdi/view?usp=sharing

Rover Data: https://drive.google.com/file/d/1vQyqjbMtYg-gIzRmsfTT05hcu8rr06eC/view?usp=sharing

When I open them up in Notepad++ I can see data, and I can see that events have been triggered, etc. I cannot figure out why they aren’t working in PPK software and giving me event positions to geotag images.

1 Like

I don’t work with drone camera events data that much, so maybe someone with more experience has an idea. From what I see, it’s like there are no events.

how can you tell that there are no events? I have confirmed with the swift console that events are triggered when I take a photo with the phantom4. Are they just not saving somehow?

Thank you for your help Gabriel, I am having a really hard time navigating all of this.

Hi Callie,

I’ve examined the .obs file from the rover you shared. As Gabriel previously mentioned, it looks like there were no time marks recorded in the log. You can check if the log contains the time marks by opening the file in any text editor. The time mark usually looks like a string with a timestamp without further observations. I have put the one in doubled asterisks as an example:

C27  23688871.920 8                     -3466.097          27.000                                                                  
C29  21138804.233 1 110075300.483 2       424.695          41.000                                                                  
C30  20341026.594 1 105921058.873 2     -2137.779          40.000                                                                  
C36  20661863.953 1 107591746.015 2       908.729          42.000                                                                  
**> 2021  4  6  9  6  1.1406823  5  0**
> 2021  4  6  9  6  1.3940000  0 29                     
G 2  20285912.578 1 106603191.180 2      1947.440          38.000                                                                  

As I understand from the RINEX header, you’ve used a device produced by Swift Navigation. I can barely figure out why this rover didn’t record the time marks as we didn’t test these devices ourselves. However, I suggest double-checking the connection between the drone’s camera and the rover. It might be that it’s not working properly.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.