Rs2 not booting and frimware flashing problem

Hi All

My device have a booting issues. Rs2 does not start and stays on the same led actions for hours.

And when I want to reinstall the firmware file on the same device, I get the UNKNOWN USB DEVICE warning on windows and frimware tool flashing failed warning.

Thank you very much for your help

Edit: Belongs to a single rs2 in two problems

Hi Akay,

Could you please contact us on with the serial numbers of these devices?

When did the devices start to behave that way?


Hi Tatiana

Yesterday made the breakdown.

There seems to be a lot of firmware flashing problems. Maybe Emlid should halt first the firmware release until these are resolved. Risky to update if an error would render the unit useless and can’t be downgraded to previous working firmware.

Hi Akay,

Thanks, I’ve received your email.

Did it behave properly before it occurred? Is there any chance anything unusual or unexpected occurred with the device?

No, there was no problem. While measuring in the field, it suddenly closed and gave this error


Have you tried to reflash other RS2 devices with the same PC? Does it work fine?

Hi Juan,

All the issues with firmware flashing reported on the forum are caused by the different reasons and might be related to both PC’s or units issues, not the flasher itself. Also, such issues might have a lot to do with some errors from the user side and we usually address them fairly quickly.

Yes i tried reflash other rs2 , rs+ and rs same pc not any problem.

Edit: I also tried with different usb cables


Thanks for this info!

I’ve just answered you over email.

That’s the point, whether it’s due to Pc or unit issues, there are issues upgrading to a certain firmware. Problem with that is that the unit becomes unresponsive after failing the firmware update.

Hi Juan,

Do you experience the same issues with your Reach RS2 units?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.