RS2 Hotspot mode is not reliable and not connecting with RV3

I was able to managed to configure the simcard with RS2 and mobile data on.after Mobile data on RS2 Hotspot signal keep disappearing at regular intervals and even when connected to RV3 it’s not reading the RS2 data and getinto the app.

Kindly look at the link of Phone screen recorder.

NOTE: without simcard I was not faced this problem after simcard and Mobile data on only I’m facing this issue.

RS2 only support 3G and 2G sim Card?it’s doesn’t not support 4G sim?

I want to know one more thing that when I try to configure RS2 base correction input tap as NTRIP it’s ask for username .

Where as in emlidcaster there is two options to configure,here base doesn’t have the username details rest of the things available.

But in rover correction setup has username and remaining same as base little bit confused about the set-up for RS2

For RS2 whether I want to configure the base Mount point information or rover mountpoint information ?.

Hi Kalai,

That looks rather strange. What if you just manually reboot the receiver? Does the issue still persist? If yes, what firmware is installed on the device?

RS2 can work with 2G/3G/3.5G.

You need to use the credentials for the base. Our Caster doesn’t provide a username for the base. So, you can leave this field empty.

Yes I was tried with manual reboot also many times but still same issue using 27.1 firmware on RS2 and M2 as well.

I was used purely 4G sim card .in future 4G sim will support?

If I leave username empty will accept the credential and send correction input for the base?

Hi Kalai,

RS2 won’t be able to work with a 4G only SIM card. I suggest double-checking whether this SIM card works with 2G or 3G. If it doesn’t, then it’s better to test with the supported ones.

I can hardly say anything about the 4G support at the moment. Usually, it’s enough even to use a 2G connection since RTCM3 messages are lightweight and don’t require higher speed.

That’s right. For the base receiver, you need to fill in the address, port, password, and mount point to transmit the corrections.

The source video posted in the thread is using 2G and 3G sim card only. But why inconsistent connection with Hotspot ?

If I enter NTRIP caster credentials to RS2 and same will vary on each reboot of RS2 or I have to check emlid caster sigin page and check for new NTRIP caster credentials .

Every unknown point RS2 placement will need different Mount point ?

I have successfully configured simcard with internet access and getting internet via Hotspot .

Now I configured my RS2 base for NTRIP correction input from emlid caster credentials as follow

But I’m not getting any NTRIP correction over the internet and correction input status shows still waiting for correction.

RS2 base still in single solution mode.where I’m doing mistake here ?

Hi Kalai,

I’m not sure why the connection with the Reach hotspot may become unstable with the inserted SIM card. But you can share the Full system report from the receiver with me, so I can check what can be the issue here. Please, send it to

The credentials for the base receiver are going to be the same. Unless you manually change them in your Emlid NTRIP Caster account.

Maybe I’ve lost some details, but it looks like you’ve configured only one receiver to be connected to our NTRIP Caster, right? The thing is that our Caster doesn’t provide the corrections itself. It can be used as a tool for transmitting the corrections between your receivers. So, you should connect your base to the assigned mount point and then connect your rover to the same mount point.

Can you explain little clear here …I’m using Reach M2 as a rover in my UAV.and it’s already using correction input method as serial ,then how come the I can enter NTRIP Mount point?

Hi Kalai,

If you want your Reach M2 to receive the corrections via NTRIP, then you need to disable Serial mode and select NTRIP. You need first to connect your RS2 to a mount point, then your M2 to the same mount point. The difference is that you configure Correction output on RS2 and Correction input on M2.

The great news is that we have recently released the guides for our Emlid Caster, so you can check the instructions on how to do that by the following link. I hope this helps!

1 Like

Actually my scenarios is ground station Radio sending base correction to the rover M2 via Serial.

Its not possible to send base RS2 correction( which received via NTRIP) to M2 rover using Serial radio as I described above.

If I have to configure M2 for NTRIP then I have to configure internet dongle right?

If you plan to configure M2 to receive the corrections via NTRIP, then you’re right.

I might have missed something, but why do you need to configure NTRIP with M2 if it’s already receiving the corrections via Serial from GCS?

I think you did not understand my concern.

I have Reach UAV mapping kit with me and configured for RTK.
Im sucessfully receiving correction from RS2 base to Reach M2 rover via serial protocol using mission planner and telemetry Radio at 57600 buadrate NMEA protocol.

There is no issue with above set-up. But I want to achieve RS2 base to be correct before sending correction to the Rover M2. for that I’m trying to connect RS2 base to the NTRIP caster using emlid caster credentials.

But still RS2 solution status is singke only it not receiving correction from the NTRIP caster.

I want to fix the RS2 base .

Now you unstand what I’m trying to do with mapping kit.

@liudmila.slepova your suggestion on this.

Hi Kalai,

I see more clearly now what you’re trying to achieve. But as I’ve mentioned above, Emlid Caster can’t provide corrections for your base. With Emlid Caster, you can pass corrections from your base to your rover. It’s like a communication link where instead of LoRa or other radio, you’re using NTRIP protocol.

To provide your RS2 with the corrections, you need to choose an NTRIP service. I can suggest you check NTRIP Caster vs. NTRIP Service: Which one to Choose? in our blog to learn more about the differences between them.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.