RS2 + Field Genius for Android 2.02.6610 Build 2021-10-28

I have Field Genius connected and working with my RS2. The issue I am having is in the stake out mode, when I click the DIRECTION+DISTANCE button, it all crashes. This is ONLY when connected to my RS2. It works before I connect. Any ideas? I can’t add a photo.

2 Likes

yah the android version has had some crashing issues. Maybe contact there support team, they are a awesome team

3 Likes

What data collector/device are you using?

Samsung A32 phone

Yeah that should be just fine. What I think is happening is that there is a memory leak in the data the receiver is collecting. It’s causing an overflow of the RAM and getting shut down by the system. I am not a software engineer but that is what I keep getting from my device’s logs. I need to try switching phones and see if it continues to happen because this was supposed to have been corrected two versions ago.

3 Likes

I’m also still experiencing crashes with the Android latest (2.02.5510) version. Was hoping that this version would have fixed the problem. At least I haven’t lost any data so far with this version. Being a bit gun shy of losing data, as soon as I have noticed a slow down in the app, I have proactively shut it down and rebooted the app. Probably about every 10-15 minutes or so. Taking about 3mins to reboot and load the project. Even taking those steps, it has all of sudden crashed on me.

It has also just started losing the connection to the receiver when shooting some points, I lost the connection with the rover about 3-4 times and 5-6 crashes in about a four hour period when testing today. Project size doesn’t seem to matter, it can happen on a 100pt or a 1000pt project.
Seems to happen more frequently on Stakeout, but it will crash in Survey mode also. I’m using their Cedar CT8 supplied tablet that came with the software package. I really like the software and the form factor of the tablet, just wished that they could get this crashing problem corrected.
Almost makes me want to save my pennies and buy one of Bryan Enfinger Javad brand receivers, though at 8 times the cost, that would be a few pennies.

1 Like

Have you tried disconnecting and reconnecting to the receiver? This has worked fairly well if I could catch it before it crashed but it doesn’t seem to last as long after that.

Michael, I have also tried disconnecting and reconnecting the receiver from the app during staking and survey and it has helped to some degree. I especially do that when traversing between points of long distances. It does seem to help, but has to be done before any slow down in the app. Once that starts happening, you may as well reboot.
Regards, Mark

1 Like

In our situation we are traversing the entire site and they average about 40 acres. We are just setting and checking control. No layout so I have a mount on my truck and drive across with it on the whole time. I usually get about 7 points consistently and I am guessing that takes about 30-40 minutes with my setup.

I usually work on less than 10 acre sites, using both survey and stakeout. It crashed on me again a couple of times today while using it for a total of 2 hours… I saw it slowing down, but before I could do anything it crashed. Luckily, I haven’t lost any data since the update. I’m using just the rover with a RTN correction service by Leica SmartNet, which has been accurate and also a great time saver for me. Overall pleased with both Emlid and FieldGenius and would be really happy if FieldGenius corrects the crashing problem.

1 Like

I experience the same issue on my CEDAR CT8 tablet.
Seems to be a FieldGenius issue

1 Like