RS2 + failed test 2 and 8

Hi, we have an urgent (because we are now on day two of a 3 day international survey visit) problem which I hope someone can help with.
On starting up our RS2+ base unit in the emlid flow app and on the diagnostic web page it reported failed tests 2 and 8.

Following suggestions on the forums we tried reflashing the unit using latest firmware reach-rs2-plus-v31.8-r0. The tool reported that reflashing was successful, but since then it does not boot - the battery lights flash continuously. wifi appears and can be connected to but the web page is not accessible and device does not appear in the list in emlid flow.

Any suggestions greatly appreciated.


What is the state of the battery? Fully charged?
(5 white LEDs when you short-press the button)

If you are desperate, try the typical troubleshooting for flashing. Flash with different USB cable; use a different USB port (because some are superior to others in the same computer/laptop), and also try with a different computer/laptop. *edit: also if there is a (black) USB2.0 port available, try using it, rather than the (blue) USB3 port.

Also try to access Reach Panel directly, rather than with the app: (if connected to RS2+'s hotspot) (if connected by ethernet-over-USB / assuming your computer has an IP for that interface in the same subnet

Hi @wjb,

Welcome to the forum!

  • Can you move Reach outside and restart it? It will help RS2+ to pass a time sync.
  • Do I understand correctly that you used IP address to access RS2+ from the Reach Panel?
1 Like

Hi, we have tried switching on outside also. We tried reach panel using and it did not connect. This is after reflashing.

1 Like


I’ve written you a PM since our next steps include discussing sensitive information.

I have replied directly to you. however, I received back an automatic response:

“Looks like you’re trying to get in touch with us, but you’ve replied to an address that is used for automated communications. Therefore there is a chance that it will not be read by our team.”

Tried a PM also through the forum but it says I am not permitted to add attachments.

please confirm if you have received?

1 Like

I got your message! Let me take a look at it and answer in a bit.

Can the other users get some insight into this problem?
“Failed Test 2” and similar fails have been around since the reach modules first came out.
I would have imagined these nagging issues would have been resolved by now


We were unable to resolve the problem ourselves and Emlid kindly offered to replace the unit.



The self-tests show us the state of the particular Reach device, so such issues are not related to the receivers’ firmware or design. If you face such difficulties, please contact us at, and we’ll provide the next steps depending on each specific case.

1 Like

Thanks for the clarification

1 Like