RS2 drops bluetooth

Just wanted to see if anyone else is having the same weird Bluetooth problem I have been having the last 3-4 reachview updates, I use lefebure ntrip client on my android phones to enable mock location to my apps. The android version I have that I am having problems with is android 10. When I start up ntrip and connect to reach it goes along fine for exactly 36 seconds then the connection to reach resets and connects to reach again, then it drops it again at 36 seconds. The google pixel 3 phone android 10 does not do this with any other bluetooth devices just reach. I uninstalled ntrip and reinstalled no change. I have tried all the bluetooth settings on the phone from insecure connection to every possible one in the advanced developer section. I have been hoping future firmware updates would fix it but it has not. Why have I let this go on? I can simply change over to one of my older android phones and this does not happen Pixel 2 etc. I would like an answer to this of course but right now I am just curious if anybody else gets this 36 second drop out reconnection thing/ Thanks!

Just tried with lefebure and RS2. No dropouts with this on my Samsung S5 Android 6.
Have dropout with other software but it has been a Android issue as far as i understand

1 Like

Hi Bryce,

Do I understand correctly that such an issue appears on Android 10 only?

We’ll try to reproduce it and get back with the news.

1 Like

Yes only on android 10 but it did not have the problem 3 firmware releases ago.

Hi Bryce,

Do you mean it worked fine with v2.16.2?

I forget the number , it worked with the original firmware and the 2nd release firmware.

Hi Bryce,

Thank you for your report!

We’re looking into this issue currently and hope to resolve it in the nearest releases.

2 Likes

Hi Bruce,

We’re still investigating this issue. Currently, we’ve managed to repeat it only on the Google Pixel. Any other device on Android 10 seems to work fine with Reach RS2.