RS2 - Dropping Bluetooth connection (Firmware v.30 Beta1)

I see that there are several other posts on this topic.

I installed the latest 30 Beta 1 firmware on my REACH RS2.

I have tried using Bluetooth connection to get NTRIP corrections from my Samsung Note 8 phone running Andoid 9.

The connection lasts for about one minute and then is lost. Connection via WIFI hotspot with the phone works fine but I would rather use Bluetooth since hotspot drains my phone battery faster.

So is this a problem with Reach Hardware , Software or Android 9. My phone does not support later versions of Android.

Interested to hear from anyone who has better experience with RS2 Bluetooth and connection to a Samsung phone.

eu tambem, mas e no wifi

what software do you use to communicate with RS2?

I am using Reachview 3

are you using BLE connection?

Today, I tested bluetooth connectivity using the RS2+ with fw 30.B1 and had good results.

Previously, BLE connectivity was hit and miss. But on 30.B1 it was solid on my devices, an iPad 6th gen (ios 14.8), or a Pixel 3 phone (android 12).
I worked with it for about 30 minutes and never had a drop that I didn’t cause.

Using the RS2+ to output corrections to Emlid Caster over bluetooth seemed problem free in this test. I had a fixed solution on another device receiving the corrections from EC.

Additional. I flashed the RS2 to 30.B1 and the BT connection is not as solid as it is with the RS2+ connecting to the Pixel 3 phone, but seems to be just as solid connecting to the iPad.

1 Like

Hi @hydrokiwi,

We are working on providing a stable connection with all devices over BLE. However, sometimes such situations can happen. Can you generate a Full System Report and send it to support@emlid.com? We need to look closer at it to investigate the issue.

Hi Anna:

Full report was sent on October 18.

Did this help?

Cheers
John

Yes, thanks for the report, I’ve answered you via email. Currently, we’re checking it, but we also need some details. I’ll double them here:

Can you test the BLE connection with Reach on iOS device? Of course, if you have one nearby. In this case, we can check if this issue is on the unit’s side or not.

Also, you can install an app on your phone that checks a BLE connection stability. Please let me know if it also drops.

Anna:

I tried installing Reachview 3 on an IPAD and connecting to Reach.

On the IPAD Bluetooth settings it says it is connected by Bluetooth to the Reach. However the Reach Bluetooth Connection does not show up in the Receivers page of the Reachview App. The WiFI connection shows up and works but no Bluetooth connection.

I tried disconnecting the WIFI connection on the Reach but then Reachview cannot see any receivers.

Cheers
John

Hi John,

I have 2 identical ipads with the exception that one is on ios 14.8 and the other is on 15.x (latest 15).

ReachView3.14 on both

The ipad running ios 14 sees the RS2 (running v.30 b1) in ReachView, but the ipad running 15 does not. I’m curious what ios version your ipad is running?

Dave

Hi Dave

Funny you asked that.

So I don’t use this iPad much, so when I booted it up it said that there was an OS upgrade.

So I have 15.7.1.

Cheers
John.

1 Like

Ah, we have a common factor, then. That is good data point for the Team.

Hi John,

Thanks for your tests! We’ll try to reproduce this issue, I get back to you once we have any news.

Hi Dave,

I see that you’re already in contact with @svetlana.nikolenko via email regarding this issue. As I said to John, we’re investigating it.

1 Like