RS2+ Correction over Serial

Hi All

I am trying to get the RS2+ RTCM3 corrections over Serial (Already had it working over TCP before).

the base is setup to send over serial:

my machine mange to see the base com port:

but when i open the port at the right baud rate, nothing comes in.

Any ideas?

Hi @guyz,

Welcome to our forum!

Can you please elaborate a bit more on how you check the stream? You may share the screenshots, for example.

Have you tried other baud rates? Just to understand whether it changes the situation.

Also, please make sure that the receiver has at least a SINGLE solution.

tried both 115200 and 38400. as you can see even with Single no data is being output.

Are you using a serial cable or a usb-cable from the RS2?


It is connected via the USB-C port, it is working when i use it for the position output, either NEMA or ERB formats, but not for the corrections RTCM format, I am aware that only one at a time can use it so when trying to get RTCM I am disabling the position data.

Hi @guyz,

Can you please send the Full system report from the receiver to I’ll check what could be the issue here.

Sent over email.

I think I found the issue, i had it waiting for Fix:

but only got single or float, once i had fix or reduced it to the right level i started getting correction.

next question is about sim data but i’ll start a new post i think

Hi Guy,

Since one of the recent updates, Reach doesn’t send the corrections until it averages its position in a specified status. So you’re right, it can explain why you didn’t get any data. Thanks for posting this!