RS2 can't connect to Wi-Fi

Hi, I seem to have a very similar problem: my RS2 (QR code translates to 82434BF3E1A26A641927). I am using RV 3 (App details show version 6.9) with Android on a Google Pixel 4. Using RV I gave the credentials of my wifi and it seemed to accept that in that now the RS2 wifi is solid blue. But with my phone now on the same wifi, this receiver does not appear when I do a refresh. Nothing changes when I power the RS2 off and then back on. It returns to the blue wifi light. I do not seem to have any options in RV. Closing the app and then re-opening just comes back to the same Receivers page. So it seems I am locked out of making any firmware update to the RS2. I am going to the field within 48 hours, and this is giving me fits. Please advise. Thanks.

After this post, I found that I could perform a firmware update and I have done so-- the version installed was version 27.1. After all this process, I am now back to a similar dilemma-- the wifi light is solid blue, and I understand that this means it has connected to a wifi signal. I have carefully input the wifi name and password. YET, with my phone connected to the same wifi, RV still does not recognize any receiver. (I pressed Refresh multiple time.) I have also gone through the firmware installation process the 2d time in case I may have missed something. I have restarted my phone as well, to no avail. So I am still hoping for some assistance. Thanks.

1 Like

Sometimes the RV3 doesn’t see the receiver and I have to close and restart the app.
To avoid this situation I do the following.

  1. Start the wifi hotspot in my phone.
  2. Power on the M2 (I own M2 not RS2 but it works the same i think)
  3. Wait the M2 led to become solid green
  4. Start the RV3
    This way RV3 sees the M2 without problems.
    Sometimes though the app struggles and loses the connection to M2 but I close and restart the app and continue.
1 Like

Yep,I had the same issue “vgo195” . I finally did the same as your suggestion. The hotspot needs to be booted first then start the receiver. Another suggestion also is the have the receiver away from any other networks. I had to go outside away from my house network so it wouldn’t try and connect with it.

From the user guide, “After the device is powered up, the blue LED will be blinking for about 30
seconds and then becomes solid. Reach M2 is now broadcasting Wi-Fi.” It is not connected to Wi-Fi when solid. If you look at your available networks on your Pixel, you will see a Reach network available as it is broadcasting.

The blue light should be flashing when connected to Wi-Fi. Double check your network setup. In order to do this if your Reach network is available, connect to it and verify network config settings.

Here is the actual link to what I was saying about slow blink verses on solid.

https://docs.emlid.com/reach/quickstart/connecting-to-the-internet

Hey everyone,

Thanks for all of your suggestions! They are definitely true for M2: to start working with the receiver, its green LED should be solid. The blinking blue LED will show that the receiver is connected to the external Wi-FI, solid blue LED - that the receiver transmits the hotspot.

The indication is a bit different for Reach RS2. On it, steady blue network LED shows that the Reach is connected to the external Wi-Fi network.

1 Like

Hi @dspare,

This looks like Reach indeed indicates that it got connected to the Wi-Fi network. If you can’t find it in the app, you can check the following:

  • your Wi-Fi network is broadcasted on 2.4 GHz only, there’s no second network with the same SSID on 5 GHz; Reach works with 2.4 GHz only but if both networks have the same name, the receiver can be confused

  • if the receiver is visible in any network scanning app; you can use Fing to scan the network, for example, on Android and iOS

Please note that you don’t have to reflash the unit each time to disconnect it from the network. You can go away from the Wi-Fi so that Reach loses the connection and then reboot it. If you have a very strong Wi-Fi signal, it may be easier to just quickly turn off the network and reboot the receiver while it’s still off.

I’d also recommend checking the behavior with other networks, like the hotspot of your phone. This video guide may be helpful. In this case, just as our uses have already suggested here, be sure to start the hotspot before turning the receiver on.

1 Like

Sorry, for some reason when I read his post, I thought he said M2. Hate giving bad advice!

1 Like

Thanks to each of you for timely and helpful responses. I am now connected to my RS2 devices.

2 Likes

Hi @jp-drain-sol,

Not bad advice, just a bit off, nothing to worry about :slight_smile: We got to the point, in the end, that’s what matters!

Hi @dspare,

That’s good news, thanks for sharing it! Be sure to let us know how your surveying job goes :slight_smile:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.