RS+ will not boot after firmware update


My two RS+ units have just had a firmware update. The first unit was successful and is working fine. The second unit failed to update and now will not boot up when switched on. All three lights are flashing in succession as though in boot up sequence, but this continues without end. I cannot get any communication with ReachView3.

Is there anything I can do to reset the unit?

Hi @boatgypsy,

Does anything change when you force reboot this device? You need to hold the power button for at least 15 seconds. Once the LEDs are off, release the button. Then, turn on the receiver again.

Please, let me know how it works for you.


Julia is dealing with a ticket on this now, but no, forcing it to reboot does nothing. I’ve tried fully charging it, this also does not change anything. Ive tried connecting to the firmware flashing tool, which cannot find the device.

All three lights flash continuously in sequence which suggests to me it is getting stuck at an early stage in power up self test.


Hi @boatgypsy,

I see; thanks for letting me know! I’ll pass this topic to Julia then, so we don’t mix all the details.

Hi Ian,

I’ve just answered you via email. Let’s continue our conversation there to keep all the info in one place.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.