RS NTRIP no Fix

I have tried to receive fixes via ntrip with the emlid caster and rtk2go but have not been able to do so.

can connect my base antenna without problem but when I put the credentials in my rover antenna it does not receive corrections.

Can you confirm that the Ntrip tab works well on Reach RS antennas (v.27.1)?

Hi @erro.alfaro88,

If you’re using ReachView 3 to set the NTRIP settings, all should be well. Usually, it’s a little configurational error that leads to such issues. So let’s get the most obvious out of the way:

  • check that both base and rover are connected to the Internet
  • in case of using Emlid Caster, check that base is online in your dashboard (when it transmits corrections)
  • double-check the credentials; it’s also vital to keep the mount point spelling the same on both rover and base

If all is fine with these, see if you can get the corrections on any other device. You can swap the receivers, for example, so that they change their roles.

In case nothing changes, please, share the simple system reports from both units with me. They can help me see the current settings on the units. I’ll see if something is askew.

1 Like

I just updated to 27.1 and I too have lost ntrip corrections. Both devices are connected to the same hotspot that I ran our first Rover off of and NTRIP shows connected. Satellites show up for the Rover but none for the base. Additionally when I tried to change the communication to erb for fieldgenius it says write error.

Simple system report
app version: 27.1-r0
current_network:
  ip: 192.168.1.67
  security: wpa-psk
  ssid: DRONE
enabled: true
mode: client
base_mode:
  base_coordinates:
    accumulation: 120
    mode: single-and-hold
  output:
    io_type: 'off'
    settings:
      cloud:
        mount_point: ''
      lora:
        air_rate: 9.11
        frequency: 902000
        output_power: 20
      ntripsvr:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
      serial:
        baud_rate: 38400
        device: ttyEXTS0
      tcpcli:
        address: localhost
        port: 9001
      tcpsvr:
        port: 9000
  rtcm3_messages:
    message_1004:
      enabled: false
      frequency: 1
    message_1006:
      enabled: true
      frequency: 0.1
    message_1008:
      enabled: false
      frequency: 0.1
    message_1012:
      enabled: false
      frequency: 1
    message_1033:
      enabled: false
      frequency: 0.1
    message_1074:
      enabled: true
      frequency: 0.5
    message_1084:
      enabled: true
      frequency: 0.5
    message_1094:
      enabled: true
      frequency: 0.5
    message_1124:
      enabled: true
      frequency: 0.5
    message_1230:
      enabled: true
      frequency: 0.1
bluetooth:
  enabled: false
  pairing:
    discoverable: false
    pin: '***'
correction_input:
  base_corrections:
    io_type: ntripcli
    settings:
      bluetooth:
        send_position_to_base: false
      cloud:
        mount_point: ''
        send_position_to_base: true
      lora:
        air_rate: 9.11
        frequency: 902000
        output_power: 20
        send_position_to_base: false
      ntripcli:
        address: rtknet.com
        mount_point: VRS_RTCM23_NAD83_2011
        password: '***'
        port: 2102
        send_position_to_base: true
        username: rtchas01
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        send_position_to_base: false
      tcpcli:
        address: localhost
        port: 10001
        send_position_to_base: true
      tcpsvr:
        port: 10000
        send_position_to_base: true
device:
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  role: null
  rv3_banner_shown: true
  usage_analysis_accepted: true
logging:
  logs:
    base:
      autostart: false
      format: RTCM3
      started: true
    correction:
      autostart: false
      format: RTCM3
      started: true
    raw:
      autostart: false
      format: UBX
      rinex_options:
        logging_interval: 1
        marker_name: null
        pole_height: null
        satellite_systems:
          beidou: false
          galileo: false
          glonass: false
          gps: true
          qzss: false
          sbas: false
        time_adjustments_enabled: false
      started: true
    solution:
      autostart: false
      format: LLH
      started: true
  settings:
    debug: false
    interval: 24
    overwrite: true
network:
  tcp_over_modem: false
position_output:
  output1:
    io_type: bluetooth
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: ERB
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
  output2:
    io_type: 'off'
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
positioning_settings:
  elevation_mask_angle: 15
  glonass_ar_mode: false
  gnss_settings:
    positioning_systems:
      beidou: false
      galileo: true
      glonass: true
      gps: true
      qzss: false
    update_rate: 5
  gps_ar_mode: fix-and-hold
  max_horizontal_acceleration: 1
  max_vertical_acceleration: 1
  positioning_mode: kinematic
  snr_mask: 35
sound:
  mute: false
  volume: 100

It seems that all I have to do is post a question on this forum and I find the answer in milliseconds. The mount point defaulted to rtcm 2 instead of 3. I switched to 3.1 and got a fix within 5 seconds. I’m assuming it is 3.1 correct? And not 3.2? Unfortunately I don’t have the other rover in my possession. I guess I should write down stuff like that.

3 Likes

I have my Reach RS antennas since 2018 and have used the Ntrip protocol to work with them on several occasions.

I can confirm that in v27.1 the Ntrip and LoRa functions do not work correctly with the Reach RS antennas.

share screenshots of the malfunction.

Ntrip.
Base antenna.

Reachview3.

Reachview2.

My antenna is online in emlid caster.
But my rover is not getting corrections even though I was able to choose my mount point (MP226).

Rover antenna.

Reachview3.

Reachview2.

And LoRa.

Base.
Rv3.

Rv2.

Rover.

Rv3.

Rv2.

I hope they can solve the problems that v27.1 presents, I can not use my antennas to do my work.

1 Like

Hi Michael,

The magic of this forum, truly :slight_smile:

Indeed, the different formats of corrections can be at fault as well. We’re working with RTCM3.2 only, not RTCM2. That’s what’s needs to be kept in mind.

1 Like

Hi @erro.alfaro88,

Thanks for the screenshots! They help us with the mysteries faster.

Currently, on both of your devices, there is No Solution status. This means that none of them see the satellites. This way, base indeed sends nothing: it sees nothing. As the stream is not established, you get errors with the caster.

So to get a fuller idea here, I’d suggest going outside and establishing at least Single on both devices. This way, when you connect both units to the Internet, we will at least be sure that the base sends the corrections.

Also, I deleted the screens with your caster details. They helped a lot! But these are your personal credentials, it’s usually better to keep them private.

2 Likes

Ok, v3.1 appeared to be working but i’ll switch to v3.2. Thank you.

*edit - I just went to change the setting and realized our NTRIP only has v3.1 for VRS. They have another mountpoint showing v3.2 but it is annotated as G3 so i’ll need to find out from them what the difference is. Does it matter?

Hi Michael,

Seems like I misled you, sorry! RTCM3.1 is also okay :slight_smile: The main thing is that we don’t work with RTCM2 in any shape.

1 Like