RS+ Not Getting Fix Solution even when in LOS

Hey all,

So I’ve been trying to get a pair of RS+ units to work together and for the rover to get a FIX solution, but I have had no such success for anything longer than a .5 second. I have read through the Quickstart Guide multiple times and searched this forum many times, trying new things each time but to no avail. I have attached screenshots of the ReachView App settings for both the rover and the base. My AR rarely spikes above the 2.7 threshold for the Fix Solution and it never stays longer than a second or so.

Post your Simple Report. Of each base & rover.

https://docs.emlid.com/reachrs/common/tutorials/downloading-files/

Your elevation mask angle is too tight, set back to 15 deg. your clipping the amount of sats needed. The more the better. That goes for sat. constellations also in your region.

Do you have clear sky view? Or lots of tall buildings and trees etc? Next to high voltage lines or high electromagnetic interference such as welding machines or alien space ships? :upside_down_face:

Set base update rate to 1Hz, the rover to 5Hz.

For testing, use about 2 min instead of 30 min for base mode average single. You shouldn’t need that long anyways. If you need longer, deal with later after u gets things tweeked. Or better yet, set on a known point if you can after for better precision.

3 Likes

Is your baseline really about 47.5m, prob not. AR validation ratio has to be 3 or higher anyways.

It is a reasonably clear view of the sky. I on a couple large grassy fields in the middle of a college campus. I set it back to 15 for both rover and base.

Base

Simple system report
app version: 2.16.2-r0
'wifi_status, interface: wlan0':
- wifi_mode: ap
- access_point:
band: bg
channel: 1
password: null
ip: 192.168.42.1
is_added: true
is_connected: true
mac_address: 6C:21:A2:3A:17:2E
security: wpa-psk
ssid: reach-base:E5:90
uuid: 3af849cb-d7ef-400e-a976-ebc9721241f6
base mode:
base coordinates:
accumulation: '30'
antenna offset:
east: '0'
north: '0'
up: '2.065'
coordinates:
- '37.13922032'
- '-80.55165455'
- '524.286'
format: llh
mode: single-and-hold
output:
enabled: true
format: rtcm3
path: lora
type: lora
rtcm3 messages:
'1002':
enabled: true
frequency: '1'
'1006':
enabled: true
frequency: '0.1'
'1010':
enabled: true
frequency: '0.5'
'1097':
enabled: true
frequency: '0.5'
'1107':
enabled: false
frequency: '1'
'1117':
enabled: false
frequency: '1'
'1127':
enabled: false
frequency: '1'
gps:
enabled: false
frequency: '1'
qzss:
enabled: false
frequency: '1'
bluetooth:
discoverable: true
enabled: true
pin: '***'
correction input:
input2:
enabled: false
format: rtcm3
path: ttyMFD2:38400:8:n:1:off
send position to base: 'off'
type: serial
input3:
enabled: false
format: rtcm3
path: :9028
type: tcpsvr
logging:
base:
format: RTCM3
started: true
version: null
correction:
format: RTCM3
started: true
version: null
interval: 24
overwrite: true
raw:
format: UBX
started: true
version: null
solution:
format: ENU
started: true
version: null
lora:
air rate: '18.23'
frequency: 868100
output power: '20'
position output:
output1:
enabled: false
format: llh
path: :9001
type: tcpsvr
output2:
enabled: false
format: llh
path: :9001
type: tcpsvr
output3:
enabled: true
format: enu
path: :2014
type: tcpsvr
output4:
enabled: true
format: llh_ext
path: :2015
type: tcpsvr
rtk settings:
elevation mask angle: '25'
glonass ar mode: 'on'
gps ar mode: fix-and-hold
max horizontal acceleration: '1'
max vertical acceleration: '1'
positioning mode: kinematic
positioning systems:
compass: false
galileo: true
glonass: true
gps: true
qzs: true
qzss: false
sbas: true
snr mask: '35'
update rate: '1'

Rover

Simple system report
app version: 2.16.2-r0
'wifi_status, interface: wlan0':
- wifi_mode: ap
- access_point:
band: bg
channel: 1
password: null
ip: 192.168.42.1
is_added: true
is_connected: true
mac_address: 6C:21:A2:3A:0C:DE
security: wpa-psk
ssid: reach-rover:1A:83
uuid: e19022e2-5605-4813-843a-e1e5add89b8b
base mode:
base coordinates:
accumulation: '2'
antenna offset:
east: '0'
north: '0'
up: '0'
coordinates:
- '0'
- '0'
- '0'
format: llh
mode: single-and-hold
output:
enabled: false
format: rtcm3
path: tcpsvr://:9000#rtcm3
type: tcpsvr
rtcm3 messages:
'1002':
enabled: true
frequency: '1'
'1006':
enabled: true
frequency: '0.1'
'1010':
enabled: true
frequency: '1'
'1097':
enabled: false
frequency: '1'
'1107':
enabled: false
frequency: '1'
'1117':
enabled: false
frequency: '1'
'1127':
enabled: false
frequency: '1'
bluetooth:
discoverable: true
enabled: true
pin: '***'
correction input:
input2:
enabled: true
format: rtcm3
path: lora
send position to base: 'off'
type: lora
input3:
enabled: false
format: rtcm3
path: :9028
type: tcpsvr
logging:
base:
format: RTCM3
started: true
version: null
correction:
format: RTCM3
started: true
version: null
interval: 24
overwrite: true
raw:
format: UBX
started: true
version: null
solution:
format: ENU
started: true
version: null
lora:
air rate: '18.23'
frequency: 868100
output power: '20'
position output:
output1:
enabled: false
format: llh
path: 192.168.42.1:9001
type: tcpcli
output2:
enabled: false
format: llh
path: localhost:9001
type: tcpcli
output3:
enabled: true
format: enu
path: :2014
type: tcpsvr
output4:
enabled: true
format: llh_ext
path: :2015
type: tcpsvr
rtk settings:
elevation mask angle: '25'
glonass ar mode: 'on'
gps ar mode: fix-and-hold
max horizontal acceleration: '1'
max vertical acceleration: '1'
positioning mode: kinematic
positioning systems:
compass: false
galileo: true
glonass: true
gps: true
qzs: true
qzss: false
sbas: true
snr mask: '35'
update rate: '5'

It wouldn’t let me upload the files.

This was during one of the point collections, but the current location is in the middle between the camera location and the tripod about center image in the distance.

That’s probably your problem. See what you get. You may need to provide some photos of your environment.

Edit: environment prob fine.

Photo added in previous post.

So I went back out there after reading your post and it said it had a fix with 999.9 AR, but as soon as I walked 3m away, without moving the rover, the AR dropped back down to 1.0 and didnt recover. I told it to reaccumulate data for the base and I’ll let you know if maybe that fixes it.

See your in VA. You have the correct sat constellations selected. Good.

Keep in mind, depending on time and region, your can swap the GLONASS for BEIDOU to see if you get a better fix, more sats etc. But stick with GLONASS for now for testing.

Download, very very useful. Just make sure you set up correct time zone , region etc. L1 band selection:

1 Like

I’d restart BOTH receivers from scratch. Set the base up first, start accumulation for 2 min. Then the ROVER.

Fyi, best to set BASE up in the best spot for maximum clear sky view…and high as possible, but stick with what you have for now. I.e
Not next to a tree or building.

When you collect/stake points with rover, its inevitable you’ll go from fix to float… but depends… that’s where the RS2 shines.

So I gave it about an hour to collect info and it wasn’t getting anywhere close to a Fix Solution. I’m gonna do some more testing with switching between BEIDOU and GLONASS, but overall, it’s not looking to good. Should I change the air rate of the the LoRa as well to 9.11kb/s?

Stick with the defaults for now with LoRa which is 9.11 kb/s. But the 18.23 kb/s should be just fine anyways, it’s what I use all the time, but I am not using long baselines. Lowering it to default may help if you have long baseline?

You usually need to adjust that when the base line starts to get really far… lower data rate for longer distances.

Roughly how far apart are the base and rover (baseline)?

make sure you start with the minimal amount (and low freq rates) of RTCM3 messages also. (too many overloads bandwidth) Then add as you go. Can do the same with the sat constellations also. i.e. start with GPS only, then add GLONASS etc.

Another good tip when things should be working and aren’t and numerous settings have been changed - just go into the settings (gear icon) and click to reset settings to default on both base and rover. Then start over.

In good sky view like the field above and with short baseline the fix should come in quickly.

2 Likes

Hi Jim,

Please share raw logs (.ubx) from base and rover. The observed behavior is indeed strange.

1 Like

I have uploaded the Rover Logs and the Base Logs through WeTransfer. I included both the log from before the restart and after. The baselines have generally been between 30 and 50m.

1 Like

Hi @jyoungusa3,

I’ve processed your logs and it seems that something in your environment causes interference for satellite signal reception.

On the attached image is displayed observation data from your base. There are a lot of cycle slips (red marks) on GLONASS satellites. Cycle slips appear at the moment when the signal is delayed or disrupted and Reach losses track of the satellite. I’d recommend using BEIDOU instead of GLONASS.

Let me know if it works for you.

2 Likes

Thanks so much! I will let y’all know what happens.

Worked great! Thanks so much!

1 Like

So what caused the problem? Was it the alien spaceship hovering nearby? :alien: What was your solution? Use BEIDOU as suggested instead of GLONASS for that area/time?

2 Likes