RS+ issues with hotspot connection

I’ve been finding the similar issues on one of my RS+ on fw27.1.

Yesterday:
When I enable the reach hotspot it allows me to connect, but when I turn the unit off then on again the hotspot is not available and it defaults to my saved wifi network. When I re-connect via my wifi network and check the wifi settings, the hotspot is not enabled.
It looks like the script is not commiting the changes to flash.

Today:
Brought the receiver into the office to download todays logs onto laptop. It connected to the saved wifi network and allowed my to log in and navigate a couple of pages then disconnected.
Checked connection via reach app on iPhone, confirmed that the receiver was intermittently available.
Connected receiver and latop to the iPhone hotspot. same results.
I ran ping -t from laptop in both instrances and found intermittent connections and high latency. (Im in an area where there are no other wifi devices, so clean air on 2.4)

Reflashed firmware 27.1 via Flash tool. The receiver is now behaving normally. Ping shows latency around 6ms.

Hi @RogerM,

Thanks for the detailed report!

By any chance, have you exported the Full system report from the receiver before the reflashing? I see that you’ve lost the connection with Reach very quickly, but I’m asking about this just in case you did that. This could really help us in the issue investigation since we can hardly say anything certain without the receiver’s data.

Hi @liudmila.slepova,

Unfortunately not. However I tried to connect, the connection was too unstable. I lost my logs too.
If it happens again, I’ll try to pull a report.

1 Like

Hi @RogerM,

Alright, I see. Thanks!

I hope it won’t happen again. But, of course, feel free to let me know about this.