RS+ EmlidFlow doesn't recognize Reach

Hello dear support team,

I have borrowed Reach RS+ devices from my colleague, and I am encountering a problem setting up the connection between EmlidFlow app and the devices.
The Reach is in hotspot modus (blue is on), and it is successfully connected by Android tablet. But - the Flow application can not detect a receiver.
By connecting both, the tablet and Reach to wi-fi using a mobile hotspot (blue is flashing), still the Flow application shows no available receivers. I tried out a few other wi-fi connections, but no success. Even I can not upgrade a firmware due to it if it would be a solution. Please help me to fix it!
The firmware on Reach: 2.16.2
EmlidFlow: 10.4

Thank you!

1 Like

Hi @Dovydas,

Welcome to the forum!

Our latest stable version is the 31.8. The RS+ has old firmware, and this could be causing the connection issue. Because it is an old version, sometimes the Emlid Flow doesn’t allow you to update via the app.

My suggestion is to update the firmware of the Reach device using the Flash Tool on your computer. It will bring the Reach to its initial state but will remove all the saved logs. After reflashing, you need to pass the First Setup.


Thank you Victor. Yes, finally i have reflashed both devices, so by this the problem was solved.
Thanks, again.