RS+ dont charge

I plugged it into a microUSB to charge, but no blinking orange light. I tried to turn it on, but nothing, no lights at all. I tried the cable on the other RS+ unit and it immediately started blinking orange to indicate it is charging, so I don’t think there is an issue with the charger or cable. I have also tested another cable and charger, and got the same response.

I left plugged in overnight hoping the extended period might somehow bring it back to life. Today the orange light has started blinking, but i still cannot get the unit to turn on.
If i hold down the power button the other lights (NET and STAT) light up, but go off as soon as i release the power button.

This is my second time this has happened to me.
But the first time works
Now I’ve been trying for 5 days and nothing

Hi Luis,

Thanks for the detailed description of the issue.

Please, share the serial number of the device via You can find it on the bottom side of the device under the barcode. It’s better to continue the troubleshooting over email as it can require the sharing of sensitive info.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.