RS+ doesn't work


I have a GNSS Reach RS+ that I use to work in the forest, almost every day.
However, when I tried to use it last week, I never managed to switch it on. When I press the “power” button, nothing happens, no LED lights come on. (For the record, I didn’t use it for about ten days, and it was when I tried to use it last week that it didn’t work).
On the other hand, when I put it on charge, the orange “PWR” led lights up and works normally (flashes during charging and becomes fixed when finished).
I don’t understand why it doesn’t turn on, I’ve already tried several things:

  • recharge it for several hours to make sure the battery is 100% charged
  • I’ve also used two different charging cables
  • press the power button for +/- 15 seconds

Do you know what I can do?

A colleague suggested I try the reflashing firmware, but I don’t know if that’s a good solution, and I don’t think it will work if the GNSS has to be switched on.

Thank you for your help,

Hi @flo.rgst,

I’ve sent you an email. Let’s continue the troubleshooting there as it may require sensitive data.