RS+, able to connect to hotspot, but not showing up in reachview, green LED continually blinks

I updated both my RS+ and RS2 yesterday to the latest version I did some survey after, I was able to connect just fine and finished the survey.

Today I am attempting to connect and download the data, however, I am unable to connect to my Rover (RS+).

Initially I started the unit, and it seemed like it was able to connect to our office wifi as normal. But I could not see it in Reachview. After a few restarts, I took it outside to be out of wifi range and started it that way.

I was able to connect to the RS+ hotspot, however it still does not show up in Reachview at all.

The green LED has been blinking steadily the entire time. I also tried starting up the RS+ and leaving it in the open for 20+ minutes to see the satellites. This green LED was blinking the same while on our office wifi as well.

I should also note that I have tried to connect to it with reachview on my ipad mini, and two different iPhones. I don’t know of any other way to connect.

Hi Grant,

Could you please run Reach RS+ in hotspot mode and go to via web browser?

This is the screen that is shown

This is interesting. Everything should work just fine according to your screenshot. Could you try connect to via the same web browser?

This is what happens without the :5000

I’m not sure why, but I’ve left it connected to the office wifi now for about 45 minutes. I was finally able to connect to it just now.


It’s great to hear that. We would still like to investigate this behavior. Since you now have access to the interface, would you please send us Full system report in

I just sent the report in for you.

1 Like

Hi Grant,

Thank you, we’ve received your logs. We’ll look into them and come back with the summary.

1 Like

I have the same problem, I cannot access the interface. Hopefully they can find a solution.

Hello, I would like to know if you have been able to investigate this issue, since I have the same problem.

Hi Ivan,

We can confirm that there is a software bug on some Reach RS+ units behaving like this after the update. The good news is that we were able to localise the issue and we are working on fix at the moment.

I will let you know once the fix will be released.

1 Like

Hi Ivan, Grant,

I’m reaching out to confirm that we’ve released the new v2.22.6 firmware update that should resolve the issues with the green LED blinking behaviour.

Update is available through the Reach Updater page. All you have to do is to type the following to the address bar: Reach's_IP:5000. A Wi-Fi connection with an Internet access is needed to perform an update.

Please note that the fix for this behaviour in the dev branch will be in the v2.23.9 version. We’re working on the releasing it as soon as possible. I’ll reach out with the update as soon as it will be available.

Yesterday I updated the equipment, did tests and everything worked correctly. Today, the problem returned, the green led is not solid.

Hi Ivan,

I wrote a message to you in your PM. Could you please check it?

Hi Artem,

I updated my RS+ with 2.22.6 and completed two surveys. Unfortunately, I’m attempting to download the data back at the office, and the same blinking green light issue is still happening this time.

Hi Grant,

The v.2.22.7 is already on its way. It will be released today or tomorrow and it should resolve that issue.

1 Like

Hi Grant, Ivan,

The 2.22.7 is out. Could you please update your receivers and check whether the issue persists?

In order to update, please, log in onto the Reach Updater page by typing Reach's_IP:5000 into the browser prompt.

Please, keep me posted on your progress.

Thank you.

Well, I think it worked. But I will be unable to test with the RS+ further, as it was destroyed today.