Rplidar A3 USB connection

I am trying to connect RPlidar A3 on my navio2 from USB What is the configuration and connection for RPLIDAR?

Hi @edd9615,

To connect RPLidar to Navio2 using USB, please, follow these steps:

  • First, specify some launching options:

    TELEM2="-D /dev/ttyUSB0"
    ARDUPILOT_OPTS="$TELEM1 $TELEM2"

  • Then, using Mission Planner, set:
    SERIAL2_PROTOCOL = "11"
    SERIAL2_BAUD = "57"

Also, there is a guide about ArduPilot and RPLidar A2 integration in the ArduPilot docs. This should apply to RPLidar A3 as well.

Hi @svetlana.nikolenko
rplidar a3 is not rotating the configuration is shown in the images

I followed the steps on this page but had no results with BAD LIDAR Heatlh error

!
IMG_20200325_090136|412x550

Hi @edd9615,

According to the ArduPilot docs, this message appears because the rangefinder isn’t enabled for landing.

To get rid of this, you need to set the RNGFND_LANDING parameter.

en rover no existe ese parametro

Hi @asilva,

You’re right. This parameter is for Planes only.

So, I’ve researched the Ardupilot forum and found that some users reported the RPLidar must be powered up before the flight controller. Otherwise, the " BAD Lidar health" message appears. This issue was also registered on the Ardupilot’s GitHub.

P.S. May I ask you to post your answer in English? It’d be nice if other users could participate in the discussion.