Hi, I have some problems with the rover. I don’t have escs for the motors. And in mission planner they don’t let me calibrate the Navio2 in rover mode because i didn’t connect it via com(usb). How can I calibrate it in rover mode? And how can I fix the motor?

What do you try to do? What do you want to calibrate? Missionplanner allows all functions through all supported connection types.
And your video is private.

I connect my Navio2 via tcp.

Do not use the wizard. It will try to flash the firmware and that does not work with the Navio.

1 Like

Ok. Thanks. And with the motor problem what should i do?

Sry. I was on mobile data yesterday and could not watch your video. I think, you meant you have no servo on your rover for steering. What you need is the skid steering mode. You can enable it in the full parameter list.
There should be 2 options:
Skid_steer_in if you have a tank style controller or setup your normal transmitter to output a combined signal (it is basically like elevon mixing for airplanes)
Skid_steer_out if you use a normal transmitter with no mixing enabled.
The last time I used Ardurovers version of skid steer, the mixing was less than optimal.
It would apply only 50% of steering input to the motors. Meaning if the rover was standing still and you apllied full left or right stick, the wheels would only turn at half the possible speed in opposite directions. For rovers with a lot of drag (like a 6 wheeler) that made it impossible to turn on the spot on some surfaces.
If your ESC has a build in mixing function, try to use it and let Ardurover think you use Motor+Servo setup
You also should have a look at

1 Like