Rover Setup

Whenever I run sudo APMrover2 -A udp: it says it was not found.

I am able to run the copter -quad fine as i have been doing with my navio but on a new sd card with the deb installed as shown below the command is not found.

pi@navio-rpi ~ $ wget
–2015-05-16 18:59:39--
Resolving (…
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: 13373960 (13M) [application/x-debian-package]
Saving to: `apm.deb’

100%[======================================================================>] 13,373,960 561K/s in 24s

2015-05-16 19:00:03 (537 KB/s) - `apm.deb’ saved [13373960/13373960]

pi@navio-rpi ~ $ sudo dpkg -i apm.deb
Selecting previously unselected package apm.
(Reading database … 37132 files and directories currently installed.)
Unpacking apm (from apm.deb) …
Setting up apm (3.1.0a) …
pi@navio-rpi ~ $ sudo APMrover2 -A udp:
sudo: APMrover2: command not found
pi@navio-rpi ~ $ APMrover2 -A udp:
-bash: APMrover2: command not found

What could be causing this?

Does it work if you try to run /opt/apm/bin/APMrover2 ?

Sudo /opt/apm/bin/APMrover2 worked.
Thanks, I reformatted, reflashed the card ,and reinstalled APM.deb to no avail and that’s all it took.

I’ll post some pics of the project soon too.


I think the problem lies in the apm binaries path is not in your PATH environment variable. You could try to make a symlink so you can just type sudo APMrover2 anywhere:
ln -s /opt/apm/bin/APMrover2 /usr/local/bin/APMrover2

@benrexwinkel @matthewbrooks

There was a problem in the deb package that was caused by the inconsistent APM binaries naming.

For now the solution, @benrexwinkel has come up with, does a great job fixing the issue. You also need to type sudo before ln to have enough permissions to write to /usr/bin.

The issue will be fixed in the next package update later this week. Sorry for the inconvenience and thanks for pointing out the problem.