Rover - motor problems


I have some problems with the rover mode again. I am using a Roboteq driver for 2 brushless motors. I use : sudo ArduRover -C tcp: It is in tank mode.

What can I do?

Your video shows, your rover is in HOLD mode. It is working perfectly well, so to say, because the HOLD mode does exactly that, hold your rover in one place. You have to change the mode to manual (via Missionplanner or your radio) to get a reaction from the motors.
Your screenshot shows Ardurovers normal reaction, if you switch into Auto mode and there is no valid mission present.
For safety reasons, Ardurover switches into Hold mode.

Thanks for tips but just one motor starts.

Did you use the roboteq controller before?
Have you connected it directly to the receiver and does it work that way?

It’s the first time when I use this controller. Yes with the receiver is working.

I did it. Thanks.

Ok, I try to walk you through:

  1. Disable all mixing in your transmitter. Just a plain new model, where one stick controls one channel.

  2. I assume you want to go forward and backwards with your rover, so
    make sure the right stick of your transmitter (pitch or elevator) controls throttle.
    Do this by either swapping channels in your transmitter, or changing the RCMAP options with Missionplanner.
    Futaba uses AETR channel order, so set RCMAP_THROTTLE = 2 and RCMAP_PITCH = 3.

  3. Set SKID_STEER_OUT = 1, leave SKID_STEER_IN at 0.

  4. Connect the inputs of the roboteq controller to output 1 and 3 of the Navio.

Now you should be able to control both motors with the right stick.

1 Like