Rover measures Base position

Hallo everyone
First of all thanks to the emlid team to provide a system with this capabilities for a price range accessible to a lot of people (including me :wink: ).
I am a total beginner on this field and probably the most of my questions are already answered in some way or another. The thing I want to do, and if desired to share, is producing a 3D model of a 30ha area I an alpine region with total elevation difference of 120m. If it is desired a little work report out of it I describe it better.
To get me started I need a basic issue solved:
My rover does not measure its actual position but it gives me the position of the base stationPoint%20Plot

I measured 115 points all fix with an auto rule of 10 s data collection precision 0.01m and DOP =2
The problem is that I moved the rover in an approximately 6m grid on a 0.6 ha field and all points collapsed on the position of the base station within a 1 cm circle. I mean, I appreciate the precision but I have a slight feeling down my guts that I have set up something horribly wrong.
following my app settings and a system report

Summary

Modul%202%20settings
Modul%202%20RTK%20settings
Modul%202%20Corection%20Input
Modul%202%20position%20output
Modul%202%20Base%20mode

Simple system report
app version: 2.10.0-r0
'wifi_status, interface: wlan0':
- Client state
- IP address: 192.168.178.42
  mac address: 90:b6:86:02:5f:d8
  ssid: FRITZ!Box 7330
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
  output:
    enabled: true
    format: rtcm3
    path: tcpsvr://:9000#rtcm3
    type: tcpsvr
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1008':
      enabled: false
      frequency: '1'
    '1010':
      enabled: true
      frequency: '1'
    '1019':
      enabled: false
      frequency: '1'
    '1020':
      enabled: false
      frequency: '1'
    '1097':
      enabled: false
      frequency: '1'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
camera:
  duty cycle: 20
  enable: false
  period: 2
  polarity: true
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: localhost:9000
    send position to base: 'off'
    type: tcpcli
  input3:
    enabled: true
    format: rtcm3
    path: ttyMFD2:38400:8:n:1:off
    type: serial
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
    version: null
  solution:
    format: LLH
    started: true
    version: null
position output:
  output1:
    enabled: true
    format: erb
    path: ttyMFD2:38400:8:n:1:off
    type: serial
  output2:
    enabled: true
    format: llh
    path: :2013
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'on'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: true
    glonass: true
    gps: true
    qzs: true
    qzss: true
    sbas: true
  snr mask: '35'
  update rate: '5'
1 Like

Could it be possible that you had the base and rover mixed up, and that you left the rover stationary and moved around with the base? I can’t think of how one could do it that way and keep the precision at 0.01m.

Maybe a more likely scenario is that you set up base and rover correctly, but when you were doing point collection your wireless device was inadvertently connected to the base unit.

If you saved the raw logs, then you could post-process the data into a position file, and also export your survey project as CSV. Then do some spreadsheet/script magic to put the correct coordinates at each survey point. Even without the survey project file, you could write a script that could produce an averaged point for any time where the rover was stationary for minimum 10 seconds.

I am curious to find out what happened!

2 Likes

hallo
I will do some testing today and hopefully it sorts this problem out but I am 100% shure that I was connected to the rover. Furthermore I have only posted the rover setup, this means the survey project is stored on the rover. This is also a systematic error because this is the third project with this behaviour and on one site I was definitely not anymore in range of the base Wi-Fi. I assume that the mistake is that I have left on the base mode toggle even on the rover and that created the problem, being rover and base at the same time.

The setting of the position output section is also kind of hard to understand for me. From a logical point of vive I don’t want the rover to send its coordinates anywhere. So is it meant to specify the format of the data internally or just in which format the rover would communicate with a third device? I don’t understand the docs in this point.
Nevertheless I am happy that with the raw logs still there with the post processing the work of 2 afternoons could hopefully be saved :grin:

Logging position saves the processed position file to your Reach.
Position Output sends position data out to another device.

If you don’t want position output, just turn it off.


It does not matter if the rover has base mode features enabled, but you might as well turn them off.

So, on the rover status screen there is a map. Do you not see the dots showing your trail as you moved the rover around? Did the distance between points seem to be correct at that time?

During the poject I am on the survey section and terefore on my mobile device I see only position in numbers and error coeficent. When I return on status the unit does not budge. :thinking: altought i saw 24 satelites, most of them with green bars an error bars besite it

Thanke you for the answers so far, it limits the error search

Hallo everyone
The issue is now solved. The problem was the enabling of base mode and/or the way of sending and receiving its own position. For a better understanding: the rover was practically its own base station and naturally all points where fix and within 1 cm, because all the moving was considered correction of the position, relative to itself it did not move. :crazy_face:

Anyway, the issue was solved by turning off: base mode, position output and additional correction on the rover. On the base I turned off: correction input, additional correction input and position output.
Then I established a radio connection
using at the base : Base mode :on, Serial, UART, and default baud rate: 56000
On the rover : correction input: on, Serial, UART, and default baud rate: 56000

Sorry for troubling you all it is quite basic that you should only enable what you need… how in most of the cases the biggest source of error is the human factor….

1 Like

Great to hear you’ve figured it out :slight_smile: