Rover does not boot if base is powered up

Could you please give more details on when/how this happens? This sort of feedback is really appreciated.

Every time the rover does not boot up, the settings go back to single_default. Most of the time I can just change back to kinematic_default, but not always.

Sometimes if I change settings in the app view on the pc/smartphone, the screen hangs up. That`s usually when the settings reset. Sometimes even the base goes back to “rover” mode.

Andreas, Nic,

Just wanted to let you know that we are testing an updated firmware that solves this issue. Sorry for the delay. If everything goes well it will be released within two days.

It turned out harder to fix than we initially thought because it is tied to low level stuff happening in the loader.

We have released new image that solves this and some other bugs, download link in the docs has been updated.

Does this update fix automatic base coordinated?

Weston,

Not yet.

We have two levels of updates:

  • In-app update trough ReachView. It lets us deliver new functions to you such as automated base coordinates, new protocols, UI features etc…

  • System level/OS upgrade has to be delivered by reflashing. Some issues can only be fixed by this method. For example the one mentioned in this post.

This bug was critical and we very focused on it mostly and had to put development of new features on hold. Now we are through it and keep working on improving Reach :slight_smile:

Hi @igor.vereninov, I already flash one of my Reach units with the fresh image (ReachImage_v1.1.zip) but when I try to connect my PC to Reach hotspot (reach:a3:36), I receive a message from my PC that password is invalid, also I try from my mobile and the system answer is identically (password is invalid) then could you confirm if is the password to access is

emlidreach

Thanks

Hi @Grek,

I have just downloaded the image, reflashed Reach and connected to wi-fi hotspot with password “emlidreach”. Everything just works. Maybe you have caps lock / wrong language settings?

Hi @igor.vereninov after post the message I try to go back with the previus version of the reach image that I downloaded on 14-12-2015, well I made all the flashing procedure… and I got the conection to the reach hotspot and my PC get connection with reach, after that I typed the address 192.168.42.1 and Intels page open and allow me to change the setings to my local network, then I made those changes I wait for wifi connection and It works… Then I reflash to the latest version again but unfortunaltelly no access behaviour still happen.
But here doesnt finish my troubleshooting, then I follow the USB ethernet access procedure on http://docs.emlid.com/reach/software-development/#connecting-to-reach-via-ssh and then @egor.fedorov on the post Reach is not creating Wi-Fi hotspot but I got the following answer when I type:

sudo wpa_cli status
Password:
Failed to connect to non-global ctrl_ifname: (null) error: No such file or directory

here the password that I use was reach
So Could you help to me to solved?
BR
JGrek

Thanks for the debugging work! While flashing the new image, have you waited until led turns green without removing power or you plugged it out right after Intel Flash tool showed “success”? I am trying to find out what we are doing differently.

Hi @igor.vereninov … yes off course I wait till led turns solid green without disconnect the usb cable during all the process…uhm could you guide tome where on which file i can check which password reach is waiting for?

I have same problem here. New to flashing, but seemed to go OK. Short on time to do testing now.

It seems to me like this update slowed down the time Reach takes to apply settings. I flashed the firmware twice because the Reach was not starting up its initial hotspot when it should have. The second time I waited and it finally applied. Although after configuring the edison, it did not join the network, it created one of it’s own, which confuses me greatly.

Hi @igor.vereninov, Well bad news for now… I reflash the second one and I got the same behaviour… :pensive:, I made the procedure three times using GUI twice and one with windows CLI.
If I get access using ethernet over USB I got acces to linux platform but when I made the procedure suggested by @egor.fedorov I got the same message that I already write before…
Now reagarding to the others ReachTeammates :smile: I think there is some little bug on the new image.
Thanks in advance for your analysis.

@Grek

I was able to reproduce your issue after reflashing it several times. My Reach has created hotspot with a name “EDISON-66-AC” instead of “reach:66:ac” right after flashing and password “emlidreach” would not let me connect.

The solution was to reboot, Reach has created a hotspot with name “reach:66:ac” and I have connected without any issues. (Tried Win8, Mac, Android, IOS). It seems like this issues is only present if you do not reboot the device after flashing.

Can you confirm that?

Hi @igor.vereninov… uhmm well after several flashing procedures (7 times)… the behavior is the same… :pensive: regarding to your topic the hotspot model was showed just only 2 times… after that the reboot was done but wifi connection was not possible. At this point I ask you a guidance to check inside of which file of the system are located the password expected for the system… Could you provide to me the path and the indications to search the file to continue the troubleshooting? Thanks (By the way merry christmas and happy new year 2016)

I duplicated the hotspot “EDISON-66-AC” type name. Paid more attention to flash procedure and waited for rebooting after flashing. Now, the two Reach units show up as “reach:66:ac” name formats. However, I still cannot connect. The units appear to be in normal Wi-Fi Hotspot mode. But still cannot get password “emlidreach” accepted. This occurred with Android, Win7, and Ubuntu Linux 14.04.

I’m still trying to see what is happening. Is there someway I may have messed up the password?

I second the appreciation of the effort that everyone at Emlid and other contributors have put into this project.

I’m in the same boat as @Grek. I had a working setup with the original firmware. After installing the new firmware, I get the “Reach:75:1f” hotspot to show up, but it will not accept the “emlidreach” password. I’ve tried on mac and win7 and also reflashed the firmware again, let it sit, rebooted, etc with no success. Any ideas? I haven’t tried it on the second unit.

Does anyone have a link to the original firmware? I can’t seem to find it.

Found the original image here: http://files.emlid.com/data/public/reach
I was able to properly connect after flashing the original image. Subsequently flashing the latest image gives the same result of not accepting the password. Going back to the original image unless someone else has suggestions.

New image? Im confused now, do we have to upload a new firmware already? Wasnt it supposed to be software updates over the app?