Can't connect to Reach Wi-Fi, password does not match

This is a topic for discussion about the issue with Wi-Fi password issue in the latest image (v1.1). I am going to move messages from other topics here to keep everything consistent.

After you started receiving units from the first batch, we got several reports that showed different behaviour after reflashing, mostly concerning Wi-Fi. We are doing our best to solve them and have released v1.1 image that improved things significantly as we were able to remove Reach one time setup and move more features to Yocto build. During one time setup we used to install some packages on your Reach and if this process failed the app would not start, now these issues are gone.

Unfortunately Intel Edison has it’s own one time setup, that is performed after flashing and seems to be the source of instabilities in Wi-Fi behaviour. Migrating this setup to the build system would be the best option and this is what we are currently working on, in the long shot it should make Wi-Fi connection reliable and easy.

This is some technical background to the issue, so that you can understand what we are dealing with.

We can see reports that you are not able to connect to your Reach hotspot as the password does not match. We are trying to reproduce this error without any luck so far, so we will need more details from you.

During reflashing please note:

  • After Intel Flash Tool shows “success” wait until Reach restarts and shows solid green. If you try to connect to the hotspot now, you will see name “EDISON_XX_XX” instead of “reach:xx:xx” and password will not match.

  • Reboot your Reach by disconnecting it from power. After reboot it will show hotspot with name “reach:xx:xx”. You should be able to connect to it with password “emlidreach” now.

If this does not help please let us know what is the name of the hotspot after reboot? Also note that MAC OS can show that it is trying to connect by blinking the wi-fi sign for longer than expected, this is because Reach hotspot has not Internet access.

Please keep this thread only for the issue when password does not match. By keeping reports separate you are helping us focus on the most important issues. Thank you.

Ok, just flashed the 1.1 firmware on to the Reach, the second one, and it is rejecting the password, ’ emlidreach ’ when I type it in… I’m confused at why this would happen. The first Reach accepted the password, the second does not

Hi @igor.vereninov, I continue trying to flash image 1.1 but It is no possible to get wifi conection for both modules.
I checked the macs also and the hotspots name for each one and the format are reach:xx:xx, then like I mention before I another thread of this topic… I flashed to a previous image and then I made an update (ver 0.0.3) for both modules for Now the RTK´s Quickstart procedure works, but I am very confused about the new image…
My question is what is the difference between ver 0.0.3 and the image 1.1? It is necesary to flash to 1.1 version? If this necesary, then I will need support to solved.
Please your clarification is necesary on this point. Thanks

The 1.1 firmware adds bug fixes, such as the Reach not booting under certain circumstances, it would be defiantly advisable to install, but not explicitly necessary unless new versions of the ReachView application require components not in previous firmware, see this: (from another topic )

Hi All,

I seem to be suffering this same problem on one of my reach modules.
It has always reported as ‘reach:a6:fa’ after a re-flash and I cannot connect with the ‘emlidreach’ wifi password. I’ve tried several power cycles and re-flashing attempts, the result is always the same. I have successfully flashed and then subsequently updated to V0.0.3 on the other module without issue.

Two additional clues that I wanted to pass on:
I think this module may have been at the earlier (as shipped) version of ‘update’ firmware (both modules had successfully been flashed with ‘V1_0’ previously)
The unit appears as a wifi hotspot with this same name, immediately after the firmware update, with the unit showing a solid green LED.

Thanks for an awesome product and I look forward to getting these up and running with the newer firmware!

Best Regards,

Same problem
the password emlidreach doesn’t work

please how can check what is the password ?
are you sure that you enter this pass for the new image ?


Hi All… Do you know is located the file where the system goes to check and validity the access?, maybe if this can be checked could be help us to solve this issue… I will apreciate your feedbacks…

Guys, the issue is not that we forgot to set the right password. For some reason on some Reach modules password check does not work. We are working to resolve this.

We have made modifications to the image that should resolve this issue and here is release candidate for v1.2. Please test it and let us know whether it solves the Wi-Fi issue for you. It also includes latest v0.0.3 ReachView inside. Please note that in Wi-Fi setup networks are not scanned anymore, so you will have to enter SSID (network name) manually.

This update is a part of ongoing work to get rid of Intel wi-fi setup which shown itself as not easy to use.

Your feedback is highly appreciated.

I’m happy to say that the release candidate for v1.2 flash went smoothly for me. Congratulations!

Both rover & base setup went well. The base signal strength bars are now on the rover signal display and the increased resolution is welcome. I will need a better location to test float and fix, as I need a little better signal to noise.

I hope the new modifications work out as well for others as it did for me.

Appreciate the effort…

Rick Johnson

Hi @igor.vereninov,
Well good news , both reach modules were update without issues…
Good Job to you and your Emlid Team .

Hy Igor
good news for the end of the year
Flash ok update ok now I tried to collect raw data gps +glo to post process



+1 for successfull connection after reflashing firmware 1.2RC - no time to try any measure

1.2RC: Was able to connect - thanks!