Roll back to a previous working version


Is there a process wherein one can roll back to previous firmware versions, or a method to download previous stable versions?


NOT SOLVED, still an open issue.


Update fails on Reach M2. Started at version 27.1, updated to 28.4, flashed with desktop app to 29, and device locks up, gets hot and solid amber light.


Hi @nfguide,

Unexpected behavior, but let’s sort it out together. Have you tried to reflash it to 29 version once again? Is it even possible? I mean, does the Flasher recognize the device?

I have tried to update to 29 three times, and no luck.

The reflashing is failed at the last step, right?

This is the important note because if so, we could try to access the device’s logs and check what’s wrong.

If it’s not recognized by the Flasher at all, I’d ask you to write to because further troubleshooting requires some sensitive info from you. Or you can share your email, so I can email you. You can do that in private messages.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.