Reach Firmware 29 update brings advanced RINEX logging and extended NTRIP protocols support

7 posts were split to a new topic: The distance is missing during the stakeout

I will have to update the shortly. I have some rapid static files from the last few days that will not adjust to nearest second via Emlid Studio 1.2. What’s odd is that I could do this with studio 1.1. Even with the new checkbox for OPUS, it’s not rounding properly. I don’t like to set the pre-defined opus logging on the base because then if you want to submit to another service like NRCAN, The interval and satellites observed are not sufficient. When doing any static work, I like to do one second (1hz) with all constellations and decemate with Emlid studio if need be. Can someone test this amount studio. I tried a couple of different rinex files and no matter what setting I try, it will not round to the nearest second. Please confirm if this is a bug in the latest Emlid studio.

Solved withrs2 flash.

1 Like

Hello all,

We updated our M2 to firmware 29 final, and the green LED light not become solid (keep blinking) but we could access and use it like normal. Is it the new change or something could be wrong?



After a few times restart, those M2 did not start, only the orange LED light was solid, the blue and green LED were off completely and we could access it via ReachView 3 app.

Does anyone have this issue?


5 posts were split to a new topic: Missing triggers on M2

I reflashed the units using PC and it worked fine again. So, something went wrong during online update by itself.


Hi Ivan,

Welcome to the community!

I agree with @ffcb, please reflash your device according to our guide. Please note that this procedure will remove all of the stored data (logs, system reports). Please let me know if it helps!

Hi Zach,

I can see that you have already checked this out in Emlid Studio thread. Just to conclude here, to apply the rounding of the seconds in the Studio, you need to convert the UBX file to RINEX for now.

1 Like

HI @l3technologycambodia,

Thanks for your report! Good to know that the reflashing procedure helped. We’ll investigate what could have gone awry during the update for your device.

1 Like

A post was split to a new topic: Roll back to a previous version

A post was merged into an existing topic: Roll back to a previous working version

A post was merged into an existing topic: Roll back to a previous working version

Hello everyone!

Today we’ve released a new Reach Firmware 29.1.
It contains a fix for some issues related to hanging in the “loading state” after the update


Hope it Fixed the M2 issue I reported above. Will try it. Thanks

1 Like

RTCM transformation would be great update, excpecialy when neede to stake points.

In Serbia, there is one NTRIP service that provides RTCM transformation ( datum and projection information, 7 parameters Helmert transformation, horizontal and vertical grid shift using bi-cubic i terpolation).

I have tried to use this service connecting to NTRIP using Fieldgenius, but only 7 parameters transformation is applied, no grid shift.

I know that Reach View 2 doesn’t support RTCM transformation for now. Does that limits FG functionality ir not? :thinking:
I think that connecting to NTRIP using FG, and FG applying corrections and transformation to measured wgs84 coordinates will overpass RV2 limitations.

My recent post on this topic
RTCM transformation using Fieldgenius ISSUE

1 Like

Hello everyone!

Today we’ve pushed a new Reach Firmware 29.2.
This release fixes rare issues related to hanging in Wi-Fi scanning mode.


why does over ntrip not work on 3G?

Hi @agrimgalina,

If 3G coverage is good in your area, it should work. ReachView 3 and Reach don’t know what type of signal you have, it just uses your mobile data. Can you describe your issues a bit more?

1 Like

I can see that more and more people notice the problem with RS2 work with NTRIP with GSM mobile data download;), maybe eventually someone will spend some time to solve this topic.