Rinex conversion using RTKLib does not produce as many satellites as using Emlid Studio

Hi. I use the Reach M2 for the drone and base station. Usually Emlid Studio is very sufficient for my work needs. However, my current work requires me to carry out up to 25 photogrammetry processes daily from scattered-multiple bases. So, I decided to process the PPK data automatically using the RTKLib AP command to make the work easier and avoid data input errors.

However, I found that there was a difference in the number of satellites between the RTKLib and ES processing results. I have tried to find the right settings but have not succeeded in finding the cause. Here is the .pos file looks like (please forget the float flag)

I have turned on all the satellites and frequencies in the settings of both software. However, in the RINEX file header after UBX conversion, I found that ES gives more frequencies and extra satellites compared to RTKlib.

I believe that this difference will greatly affect the quality of post-processing of photo coordinates. Can anyone give me the correct settings in RTKLib so it can yield the same RINEX conversion as ES?

Thank you for your help.

Hi @surveinusantara,

There are CONVBIN options that you should include in your code to have the other data you mentioned in the observation file.

Based on your screenshots, the missing ones are the doppler frequency and SNR data.
These options are disabled by default in convbin. You might want to add them to your script so these data are added to the output file.

Here, you can find more about the convbin options.


Hi @ruth.bongon ,

Thanks a lot for your help! Now my converted data is as it is converted in ES.

By the way, will the doppler frequency and SNR data affect the final results of data processing, Ruth?

Hi @surveinusantara,

Apologies for the delay in response. The SNR and Doppler data are used in solution computation in Emlid Studio. Both of these are enabled by default in the app.

Doppler is used to estimate receiver clock bias and velocity. There’s no option to remove this data in the computation in Emlid Studio, but with SNR, you can filter out low-quality signals by adjusting the SNR mask in the settings.


Hi @ruth.bongon ,

Thanks for your explanation!