Emlid

Community Forum

Return to Launch without any reason, RTL activation


(FRED) #1

Hello together,
today i tried my first flight with the EMLID Edge, the first flight was satisfying, but the second flight not:
After short time and short distance, aprox. 50-100 meters distance from Homepoint, the copter initiated a RTL- return to launch, without any reason.
I´m using an Futaba T14SG remote controller with Futaba receiver.
I restarted the copter several times, but every time i tried to fly, the same thing, it returns to home and landed.
Than i prooved every knwon parameter in QGroundControl, i disabled the [FS_EKF_THRESH] = 0
but without any success.
The RTL knob for RTL on my receiver is channel 7, but it´wasn´t activated.

What can i do?
Thank you for help!


(Andrew Yushkevich) #3

Please, share a screenshot of your Safety settings in QGC.
What are your receiver failsafe settings?


(FRED) #4

Today i had tested the copter again.
And after short fly time, the copter turns without any reason to RTL and landed.
After thar, i wish to arm and to start again, but no chance, error message apears: Mode not armable…
See my setting and error message.


(Andrew Yushkevich) #5

What flight mode do you use when receiving this message?


(FRED) #6

it was the Poshold Mode.
But i solved this in other way.
At first i had setted the RTL mode to a separate switch and channel.
Than i set it as an flight mode, and not to an separate switch, since this configuration it works.
Seems to be a bug, when the RTL mode is setted to a free channel and switch on the RC.