Renaming a Reach causes it to no longer appear in Reachview app

I am trying to set up a pair of Reach units to send/receive RTK GPS information on an autonomous boat using Ardurover with a Pixhawk controller.

I have the latest (Android) version of Reachview app (v. 2.11.0). Currently my two reach units (base and rover) are connected to my local wireless network. When I fore up the Reachview app they show up as two Reach units, reach and reach(2). Following the instructions in the docs I renamed one of these RoverReach. It promptly disappeared from the Reachview app. I can still connect to it using the IP address on my network. I reversed the name change but it still doesn’t appear in the Reachview app.

What did I do wrong and how do I fix this ?

One other question - unrelated but still a question. In the field I won’t have my network to connect to. How do I force the base reach to turn on and use its wifi hotspot?


Nigel Wattrus

Hi Nigel,

I’ve tried to rename Reach in ReachView. After changing the name and pressing ‘Save’ button, the ReachView app waits for a while and then shows green notification “Reach name was changed” in the top right corner. Is that was the same for your Reach?

Reach will automatically start when you supply the power and will use the last configured settings. If Reach doesn’t find a known Wi-Fi network, it will start in hotspot mode and you’ll see it in Wi-Fi networks list.

Once I change the name of my reach I can no longer see it in the Reachview app on my Android. The Reach has its hot spot turned on. If I connect my phone to the hot spot the app doesn’t see the reach but I can connect via my phone’s web browser - if I use the reach’s IP address (192.168.421) but not if I use its name (ReachBase.local). I have the latest version of the app and my reach has the latest stable version of the firmware installed. Has anybody else had this problem?

Hi Nigel,

Have you dealt with the issue?