Receiver is waiting for corrections

Hi All,
I have the same problem (endlessly “Waiting for corrections”) and it persists even if I am out doors and have “Single” showing with 29 satellites on the Emlid Flow app.
I have “Mobile data” and “Mobile hotspot” enabled on my Android phone.
The “Reach:OC:75” is connected on the phone’s wireless network with the annotation “Connected without internet” underneath the current network label.
I am hoping to connect to the “” correction stream and, as far as I can tell, have all of the details entered correctly.
I am running the latest 30.1 firmware and Emlid Flow says that my device is up to date although I note in the discussion above that the latest version is 31.0.
Any help would be most appreciated.

Can you share the screenshot of that ? What is the colour of the WiFi LED on the rover case ?

Hi Roger,

Welcome to the community forum!

I second Florian’s questions. To get corrections from the NTRIP service, you need to provide the receiver with a stable internet connection. And for now, it looks like your receiver doesn’t have it. This is also the reason why you don’t see available updates.

Here is the guide that can help you connect the receiver to the mobile hotspot. After you do that, I recommend you update the unit to the latest 31.8 firmware version and configure the connection to the NTRIP service once again.

1 Like

For what is worth I will share my experience. Lately I have done the following. I first set the Base coordinate using “Average Single” (5-10 seconds). This seems to solve the problem of getting corrections from Trimble. Then after getting corrections and having a FIXED solution, I will change the BASE Settings to “Average Fixed” with the desired time frame (usually 3-5 minutes).


Hi Florian,
Thanks for the response.

Images of various elements of the process attached as requested.

The left hand LED is generally white but sometimes blue.

Once the receiver is configured, should the “Mobile data” and “Mobile hotspot” be on or off?

On the subject of updates, the 31.8 update appeared in the Emlid Flow app and has been installed so it would seem that the receiver does have a stable internet connection.

I have stepped through both of the guides listed above but with no luck so far.

Many thanks.

My suggestion
The mobile data should be turned on in the related settings page, and in that case, that means a SIM card should be inserted in the Reach unit.

The white WiFi LED means the Reach is acting as a WiFi hotspot, hence it should have a connection to the Internet, given by the SIM card. The smartphone then connects to this hotspot and get Internet access too, like with your home or office WiFi network.

Julia’s suggestion below is different but works perfectly also, as long as the Reach has an Internet connection :slight_smile:

1 Like

They should be on. And your receiver should be connected to the Android’s mobile hotspot. The network LED (it’s the left one) should be solid blue.

So here are the steps to take:

  1. Connect to the Reach:0C:75 network, go to the Emlid Flow, and open the Wi-Fi tab.
  2. Add or select your Android’s hotspot and tap on Connect. At this stage, the network LED of the receiver should start blinking blue. The unit will also stop transmitting its hotspot.
  3. Disable Wi-Fi on your phone, enable the mobile hotspot and mobile data. The receiver should connect to it, and the network LED should become solid blue. If it doesn’t happen straight away, reboot the receiver.
  4. Once the network LED is solid blue, open the Emlid Flow app on your phone. The receiver should appear there.
  5. Enable correction input via NTRIP, enter your credentials, and provide the receiver with a clear sky view.
1 Like

Hi Julia & Florian,
Sorted the issue.
It turns out to have nothing to do with the Emlid Reach and the problem was that the MountPoint details appear to be case sensitive. I had entered the MountPoint details manually in lower case as it is not immediately clear to a novice user that the top field is a search field and that the required MountPoint can then be selected from the dropdown.
Sorry to have wasted your time and thank you so much for your attempts to be helpful.
Roger Greenwood.


Thank you for sharing the solution, Roger! Glad that everything works now.